<!DOCTYPE html>
<html lang="en-US">
<head>

<meta charset="UTF-8" />

<link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png">
<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16">
<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32">
<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96">
<link rel="icon" type="image/png" href="/android-chrome-192x192.png" sizes="192x192">
<meta name="msapplication-square70x70logo" content="/smalltile.png" />
<meta name="msapplication-square150x150logo" content="/mediumtile.png" />
<meta name="msapplication-wide310x150logo" content="/widetile.png" />
<meta name="msapplication-square310x310logo" content="/largetile.png" />

<title>Umbrella Academy Season 2: What Happened to Ben? | Collider</title>


<!-- This site is optimized with the Yoast SEO plugin v13.5 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Everything you need to know about Ben and his Season 2 arc on Netflix&#039;s The Umbrella Academy, plus what to expect from Ben in Season 3."/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://collider.com/umbrella-academy-season-2-ben-death-explained/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="&#039;The Umbrella Academy&#039; Season 2: Here&#039;s What Happened to Ben After That Emotional Scene" />
<meta property="og:description" content="Everything you need to know about Ben and his Season 2 arc on Netflix&#039;s The Umbrella Academy, plus what to expect from Ben in Season 3." />
<meta property="og:url" content="https://collider.com/umbrella-academy-season-2-ben-death-explained/" />
<meta property="og:site_name" content="Collider" />
<meta property="article:publisher" content="https://www.facebook.com/colliderdotcom" />
<meta property="article:tag" content="Ellen Page" />
<meta property="article:tag" content="GABRIEL BÁ" />
<meta property="article:tag" content="Gerard Way" />
<meta property="article:tag" content="Justin H. Min" />
<meta property="article:tag" content="Netflix" />
<meta property="article:tag" content="Robert Sheehan" />
<meta property="article:tag" content="Steve Blackman" />
<meta property="article:tag" content="The Umbrella Academy" />
<meta property="article:tag" content="the umbrella academy season 2" />
<meta property="article:section" content="Features" />
<meta property="article:published_time" content="2020-08-01T16:46:55+00:00" />
<meta property="article:modified_time" content="2020-08-01T17:27:46+00:00" />
<meta property="og:updated_time" content="2020-08-01T17:27:46+00:00" />
<meta property="fb:app_id" content="1738286916403753" />
<meta property="og:image" content="https://cdn.collider.com/wp-content/uploads/2020/07/umbrella-academy-season-2-ben-justin-min-social.jpg" />
<meta property="og:image:secure_url" content="https://cdn.collider.com/wp-content/uploads/2020/07/umbrella-academy-season-2-ben-justin-min-social.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="701" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Everything you need to know about Ben and his Season 2 arc on Netflix&#039;s The Umbrella Academy, plus what to expect from Ben in Season 3." />
<meta name="twitter:title" content="Umbrella Academy Season 2: What Happened to Ben?" />
<meta name="twitter:site" content="@collidernews" />
<meta name="twitter:image" content="https://cdn.collider.com/wp-content/uploads/2020/07/umbrella-academy-season-2-ben-justin-min-social.jpg" />
<meta name="twitter:creator" content="@collidernews" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://collider.com/#website","url":"https://collider.com/","name":"Collider","inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://collider.com/umbrella-academy-season-2-ben-death-explained/#primaryimage","inLanguage":"en-US","url":"https://cdn.collider.com/wp-content/uploads/2020/07/umbrella-academy-season-2-ben-justin-min-slice.jpg","width":600,"height":200,"caption":"umbrella-academy-season-2-ben-justin-min-slice"},{"@type":"WebPage","@id":"https://collider.com/umbrella-academy-season-2-ben-death-explained/#webpage","url":"https://collider.com/umbrella-academy-season-2-ben-death-explained/","name":"Umbrella Academy Season 2: What Happened to Ben?","isPartOf":{"@id":"https://collider.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://collider.com/umbrella-academy-season-2-ben-death-explained/#primaryimage"},"datePublished":"2020-08-01T16:46:55+00:00","dateModified":"2020-08-01T17:27:46+00:00","author":{"@id":"https://collider.com/#/schema/person/e6eb1ad8f808d948a4fedd3f940dab9d"},"description":"Everything you need to know about Ben and his Season 2 arc on Netflix's The Umbrella Academy, plus what to expect from Ben in Season 3.","breadcrumb":{"@id":"https://collider.com/umbrella-academy-season-2-ben-death-explained/#breadcrumb"},"potentialAction":[{"@type":"ReadAction","target":["https://collider.com/umbrella-academy-season-2-ben-death-explained/"]}]},{"@type":"BreadcrumbList","@id":"https://collider.com/umbrella-academy-season-2-ben-death-explained/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://collider.com/","url":"https://collider.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://collider.com/umbrella-academy-season-2-ben-death-explained/","url":"https://collider.com/umbrella-academy-season-2-ben-death-explained/","name":"&#8216;The Umbrella Academy&#8217; Season 2: Here&#8217;s What Happened to Ben After That Emotional Scene"}}]},{"@type":["Person"],"@id":"https://collider.com/#/schema/person/e6eb1ad8f808d948a4fedd3f940dab9d","name":"Allie Gemmill","sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//static.chartbeat.com' />
<link rel='dns-prefetch' href='//cdn.rhombusads.com' />
<link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel='dns-prefetch' href='//cdn.intergient.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://collider.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.1' media='all' />
<link rel='stylesheet' id='wpt-twitter-feed-css'  href='https://collider.com/wp-content/plugins/wp-to-twitter/css/twitter-feed.css?ver=5.4.1' media='all' />
<link rel='stylesheet' id='custom-styles-css'  href='https://collider.com/wp-content/themes/collider-v3/custom-styles.css?ver=2019_08_09_01' media='all' />
<link rel='stylesheet' id='collider-css'  href='https://collider.com/wp-content/themes/collider-v3/dist/css/style.css?ver=2019_08_09_01' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='fontawesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css?ver=5.4.1' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='collider-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C700&#038;ver=5.4.1' media='all' />
<script>
			(function() {
				/** CONFIGURATION START **/
				var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});
				_sf_async_config.uid = 66011;
				_sf_async_config.domain = 'collider.com';
				_sf_async_config.flickerControl = false;
				_sf_async_config.useCanonical = true;
				_sf_async_config.useCanonicalDomain = true;
				_sf_async_config.sections = "Entertainment,Features,TV";
				_sf_async_config.authors = 'Allie Gemmill';
				/** CONFIGURATION END **/
				function loadChartbeat() {
					var e = document.createElement('script');
					var n = document.getElementsByTagName('script')[0];
					e.type = 'text/javascript';
					e.async = true;
					e.src = '//static.chartbeat.com/js/chartbeat.js';;
					n.parentNode.insertBefore(e, n);
				}
				loadChartbeat();
			})();
		
</script>
<script async="async" src='//static.chartbeat.com/js/chartbeat_mab.js?ver=5.4.1'></script>
<script>
var rhombusSiteId = 1116384;
</script>
<script src='https://cdn.rhombusads.com/js/rh.min.js?ver=5.4.1'></script>
<script src='https://collider.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script src='https://collider.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script src='https://collider.com/wp-content/plugins/collider-core/assets/js/infinite-scroll.js?ver=5.4.1'></script>
<script src='https://collider.com/wp-content/themes/collider-v3/js/jquery.waypoints.min.js'></script>
<script src='https://use.fontawesome.com/releases/v5.2.0/js/all.js?ver=5.4.1'></script>
<script>
var tyche = { 
			mode: 'tyche', 
			config: '//config.playwire.com/1024303/v2/websites/72710/banner.json',
			};
</script>
<script src='//cdn.intergient.com/pageos/pageos.js?ver=5.4.1'></script>
<link rel='https://api.w.org/' href='https://collider.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://collider.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://collider.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.1" />
<link rel='shortlink' href='https://collider.com/?p=915883' />
<link rel="alternate" type="application/json+oembed" href="https://collider.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcollider.com%2Fumbrella-academy-season-2-ben-death-explained%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://collider.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcollider.com%2Fumbrella-academy-season-2-ben-death-explained%2F&#038;format=xml" />
		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
				(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
				m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

			ga('create', 'UA-1446295-1', {
				'cookieDomain': 'auto',
			});
			ga('send', 'pageview');

		</script>

				<meta property="fb:pages" content="160246414365" />
							<meta property="ia:markup_url" content="https://collider.com/umbrella-academy-season-2-ben-death-explained/?ia_markup=1" />
				<link rel="amphtml" href="https://collider.com/umbrella-academy-season-2-ben-death-explained/?amp"><style>
    #footer ul.social-container a:hover, #footer ul.social-container a {
        color:#666;
}
    .top-bar-social a svg {
        font-size:1.2em;
}
    .svg-inline--fa {
        vertical-align: -.2em;
}
aside.rightpanel > div > div#tyche_trendi_video_container {
    bottom: 0px !important;
}
</style>
<!-- Bing Auth -->
<meta name="msvalidate.01" content="F97A06145E9767C313B356E7E5B833F3" />


<!-- Typekit -->
<script src="https://use.typekit.net/cui2tsb.js"></script>
<script>try{Typekit.load();}catch(e){}</script>

<meta http-equiv="content-type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="width=device-width" />
<link rel="profile" href="http://gmpg.org/xfn/11" />

<!--[if lt IE 10]>
<script src="https://collider.com/wp-content/themes/collider-v3/js/modernizer.dev.js" type="text/javascript"></script>
<![endif]-->
<!--[if lt IE 10]>
<link rel="stylesheet" type="text/css" media="all" href="https://collider.com/wp-content/themes/collider-v3/iestyle.css" />
<![endif]-->


<meta name="google-site-verification" content="gsAKhpFeAT_1KIdd1PZiPoj3BdAcIipM2VNYcJKuQBU" />
<!-- Google Newsstand  -->
<meta name="google-site-verification" content="rtgRWlKYqmg2IwU4e9PBjtt31jXoTjotyW6iJbyqdyc" />

<meta name="verify-v1" content="ag44RccQF3Xr4VqGQnxB+TOx8+rCP4SHaCwwGAtuWzc=" />


<meta property="fb:app_id" content="190932086012" />

<link rel="alternate" type="application/rss+xml" title="RSS Feed" href="//collider.com/feed/" />


<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function()
{n.callMethod? n.callMethod.apply(n,arguments):n.queue.push(arguments)}
;if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','//connect.facebook.net/en_US/fbevents.js');
fbq('init', '1628636477376373');
fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1628636477376373&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->


<!-- FB Instant Articles -->
<meta property="fb:pages" content="160246414365" />
<link href="//cdn.novelty.media/css/styles.css" rel="stylesheet">
</head>

<body class="post-template-default single single-post postid-915883 single-format-standard organic entertainment features tv two-column right-sidebar">

<!-- google custom search script-->
<script>
  (function() {
    var cx = '005219487631012611056:j1axwmmwl-e';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = (document.location.protocol == 'https:' ? 'https:' : 'http:') +
        '//www.google.com/cse/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>

<!-- this is for the facebook comments at the bottom of single.php -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<!-- end FB comments -->

<script>
    window.fbAsyncInit = function() {
        FB.init({ appId : '1678638095724206', xfbml : true, version : 'v2.6' });
    };
</script>


<!-- facebook messenger overlay -->
<div class="overlay" id="complex-overlay">
  <div>
    <div class="overlay-modal overlay-modal--dark">
      <a class="overlay-modal__close">
        <i class="fas fa-times"></i>
      </a>
      <div class="overlay-modal__header">
        <i class="cmplx-icon icon-collider"></i>
      </div>
      <div class="overlay-modal__content modal-content">
        <h2 class="modal-content__title">Facebook Messenger</h2>
        <div class="modal-content__body modal-body">
          <div class="modal-body__line">Click the button below and wait for a message from our Facebook bot in Messenger!</div>
          <div class="modal-body__line">
            <div class="fb-messenger-button">
              <div class='fb-send-to-messenger'
              data-messenger_app_id='1678638095724206'
              data-page_id='160246414365'
              data-ref='block_id_580fc416e4b061a942b85b75'
              color='blue'
              size='large' >

            </div>
          </div>
        </div>
      </div>
    </div>
  </div>
</div>
</div>
<!-- end facebook messenger overlay -->

<section id="page-header">

    <div id="complex-navbar">
        <nav class="navbar navbar-default" role="navigation">
            <div class="container">
                
<section class="navbar-section global">
    <!-- Logo & Hamburger -->
    <ul class="title-area pull-left">
        <li class="menu-button">
            <a href="javascript:;" class="slideout-menu-toggle" toggle-complex-menu><i class="fa-icon fas fa-bars"></i></a>
        </li>
        <li class="logo">
            <a ng-href="/" href="/" target="_self" ga-link ga-category="Main Header" ga-action="Click on main logo">
                <img id="collider-header-logo-image" src="https://collider.com/wp-content/themes/collider-v3/images/Collider_Logo_Dark.png" / alt="Collider.com">
            </a>
        </li>
    </ul>



    <!-- Main Navbar Links -->

    <div class="menu-navbarmenu-container">
        <ul id="menu-navbarmenu" class="link-area menu pull-left hidden-xxs">
            <li id="nav-menu-item-389649" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category">
                <a href="/all-news/" class="menu-link main-menu-link" ga-link="" ga-category="Navbar" ga-action="Click on channel name in navbar">Movie News</a>
            </li>
            <li id="nav-menu-item-389651" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category fancy">
                <a href="/tv/" class="menu-link main-menu-link" ga-link="" ga-category="Navbar" ga-action="Click on channel name in navbar">TV News</a>
            </li>
            <li id="nav-menu-item-389653" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category">
                <a href="/trailers/" class="menu-link main-menu-link" ga-link="" ga-category="Navbar" ga-action="Click on channel name in navbar">Trailers</a>
            </li>
            <li id="nav-menu-item-movie-talk" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category fancy">
                <a href="/tag/netflix/" class="menu-link main-menu-link" ga-link="" ga-category="Navbar" ga-action="Click on channel name in navbar">Netflix</a>
            </li>
            <li id="nav-menu-item-movie-talk" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category fancy">
                <a href="/newsletter/" class="menu-link main-menu-link" ga-link="" ga-category="Navbar" ga-action="Click on channel name in navbar">Newsletter</a>
            </li>
            <li id="nav-menu-item-movie-talk" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category fancy">
                <a href="/video-games/" class="menu-link main-menu-link" ga-link="" ga-category="Navbar" ga-action="Click on channel name in navbar">Video Games</a>
            </li>
        </ul>
    </div>

    <!-- Right Nav Section -->
    <div class="top-bar-social pull-right">

        <ul class="search-container pull-right hidden-xs">
            <li class="search-bar has-form">
                <div class="complex-search">
                                    </div>
            </li>
        </ul>

        <ul class="social-container pull-right hidden-xs">
            <li>
                <a href="http://www.facebook.com/collider" target="_blank" rel="nofollow" ga-link ga-category="Main Header" ga-action="Click on social links" ga-label="Facebook">
                    <i class="fa-icon fab fa-facebook-f"></i>
                </a>
            </li>
            <li>
                <a href="http://twitter.com/collider" target="_blank" rel="nofollow" ga-link ga-category="Main Header" ga-action="Click on social links" ga-label="Twitter">
                    <i class="fa-icon fab fa-twitter"></i>
                </a>
            </li>
            <li>
                <a href="http://www.youtube.com/collidervideos" target="_blank" rel="nofollow" ga-link ga-category="Main Header" ga-action="Click on social links" ga-label="YouTube">
                    <i class="fa-icon fab fa-youtube-square"></i>
                </a>
            </li>
            <li>
                <a href="https://instagram.com/collider/" target="_blank" rel="nofollow" ga-link ga-category="Main Header" ga-action="Click on social links" ga-label="Instagram">
                    <i class="fa-icon fab fa-instagram"></i>
                </a>
            </li>
            <li>
                <a rel="nofollow" ga-link ga-category="Main Header" ga-action="Click on social links" ga-label="Messenger">
                    <i class="fa-icon fab fa-facebook-messenger"></i>
                </a>
            </li>
        </ul>
    </div>
</section>
            </div>
        </nav>
    </div>

    <div id="complex-menu">
        <div class="main-menu slideout-menu" complex-main-menu>
            <div class="overflow-wrapper">
                <div class="scroll-wrapper">
                    <div class="menu-search visible-xs-block">
                                            </div>

                    <!-- Site Links -->

                    <div class="menu-complexmenuprimary-container">
                        <ul id="menu-complexmenuprimary" class="section-site menu">
                            <li id="nav-menu-item-389655" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category">
                                <a href="/all-news/" class="menu-link main-menu-link" ga-link="" ga-category="Channel Menu" ga-action="Click on channel name">Movie News</a>
                            </li>
							<li id="nav-menu-item-389657" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category fancy">
								<a href="/tv/" class="menu-link main-menu-link" ga-link="" ga-category="Channel Menu" ga-action="Click on channel name">TV News</a>
							</li>
                            <li id="nav-menu-item-389659" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category">
                                <a href="/trailers/" class="menu-link main-menu-link" ga-link="" ga-category="Channel Menu" ga-action="Click on channel name">Trailers</a>
                            </li>
							<li id="nav-menu-item-movie-talk" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category">
								<a href="/movie-talk/" class="menu-link main-menu-link" ga-link="" ga-category="Channel Menu" ga-action="Click on channel name">Movie Talk</a>
              </li>
              <li id="nav-menu-item-movie-talk" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category">
								<a href="/newsletter/" class="menu-link main-menu-link" ga-link="" ga-category="Channel Menu" ga-action="Click on channel name">Newsletter</a>
							</li>
                        </ul>
                    </div>

                    <!-- Site Extras Links -->
                    <div class="menu-section-title">More Collider</div>

                    <div class="menu-complexmenuextras-container">
                        <ul id="menu-complexmenuextras" class="section-site menu">
                            <li id="nav-menu-item-389665" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="/all-reviews/" class="menu-link main-menu-link" ga-link="" ga-category="Channel Menu" ga-action="Click on channel name">Reviews</a></li>
                            <li id="nav-menu-item-389663" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="/movie-clips/" class="menu-link main-menu-link" ga-link="" ga-category="Channel Menu" ga-action="Click on channel name">Movie Clips</a></li>
                            <li id="nav-menu-item-389661" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="/interviews/" class="menu-link main-menu-link" ga-link="" ga-category="Channel Menu" ga-action="Click on channel name">Interviews</a></li>
                        </ul>
                    </div>
                </div>
            </div>
        </div>
    </div>
</section>

<!-- Header Ad -->
	<div id="cmn_ad_tag_head" style="margin:1em 0;" class="fw_collider">
        <div data-pw-desk="leaderboard_atf"></div>
    <div data-pw-mobi="leaderboard_atf"></div>
	</div>

<div id="cmn_wrap">
    <section id="welcome">
        <header class="header">
                            <article class="slider" data-tb-region="Featured Articles">
                    <ul>
                                <li data-tb-region-item>
            <a href="https://collider.com/the-umbrella-academy-season-2-ending-explained-netflix/" rel="bookmark" title="‘The Umbrella Academy’ Season 2 Ending Explained: What Happens Next?" cat="tv">
                <img width="171" height="160" src="https://cdn.collider.com/wp-content/uploads/2020/05/umbrella-academy-season-2-ellen-page-poster-thumbnail-171x160.jpeg" class="attachment-post-featured size-post-featured" alt="" srcset="https://cdn.collider.com/wp-content/uploads/2020/05/umbrella-academy-season-2-ellen-page-poster-thumbnail-171x160.jpeg 171w, https://cdn.collider.com/wp-content/uploads/2020/05/umbrella-academy-season-2-ellen-page-poster-thumbnail-321x300.jpeg 321w, https://cdn.collider.com/wp-content/uploads/2020/05/umbrella-academy-season-2-ellen-page-poster-thumbnail.jpeg 400w" sizes="(max-width: 171px) 100vw, 171px" title="umbrella-academy-season-2-ellen-page-poster-thumbnail" />                <p id="slidertitle">‘The Umbrella Academy’ Season 2 Ending Explained: What Happens Next?</p>
            </a>
        </li>
            <li data-tb-region-item>
            <a href="https://collider.com/gundam-build-fighters-review/" rel="bookmark" title="&#8216;Gundam Build Fighters&#8217;: For Gunpla Fans &#038; the Gundam-Curious | Saturday Mourning Cartoons" cat="tv">
                <img width="171" height="160" src="https://cdn.collider.com/wp-content/uploads/2020/07/gundam-build-fighters-thumbnail-171x160.jpeg" class="attachment-post-featured size-post-featured" alt="gundam-build-fighters-thumbnail" srcset="https://cdn.collider.com/wp-content/uploads/2020/07/gundam-build-fighters-thumbnail-171x160.jpeg 171w, https://cdn.collider.com/wp-content/uploads/2020/07/gundam-build-fighters-thumbnail-321x300.jpeg 321w, https://cdn.collider.com/wp-content/uploads/2020/07/gundam-build-fighters-thumbnail.jpeg 400w" sizes="(max-width: 171px) 100vw, 171px" title="gundam-build-fighters-thumbnail" />                <p id="slidertitle">&#8216;Gundam Build Fighters&#8217;: For Gunpla Fans &#038; the Gundam-Curious | Saturday Mourning Cartoons</p>
            </a>
        </li>
            <li data-tb-region-item>
            <a href="https://collider.com/umbrella-academy-cast-character-guide-netflix/" rel="bookmark" title="&#8216;The Umbrella Academy&#8217; Cast &#038; Character Guide: A Refresher on Who&#8217;s Who Before Season 2" cat="tv">
                <img width="171" height="160" src="https://cdn.collider.com/wp-content/uploads/2020/07/umbrella-academy-hargreeves-kids-thumbnail-171x160.jpg" class="attachment-post-featured size-post-featured" alt="" srcset="https://cdn.collider.com/wp-content/uploads/2020/07/umbrella-academy-hargreeves-kids-thumbnail-171x160.jpg 171w, https://cdn.collider.com/wp-content/uploads/2020/07/umbrella-academy-hargreeves-kids-thumbnail-320x300.jpg 320w, https://cdn.collider.com/wp-content/uploads/2020/07/umbrella-academy-hargreeves-kids-thumbnail.jpg 400w" sizes="(max-width: 171px) 100vw, 171px" title="umbrella-academy-hargreeves-kids-thumbnail" />                <p id="slidertitle">&#8216;The Umbrella Academy&#8217; Cast &#038; Character Guide: A Refresher on Who&#8217;s Who Before Season 2</p>
            </a>
        </li>
            <li data-tb-region-item>
            <a href="https://collider.com/top-10-netflix-tv-shows-list/" rel="bookmark" title="The Top 10 Most Popular TV Shows on Netflix Right Now" cat="tv">
                <img width="171" height="160" src="https://cdn.collider.com/wp-content/uploads/2020/07/shameless-season-10-thumbnail-171x160.png" class="attachment-post-featured size-post-featured" alt="shameless-season-10-thumbnail" srcset="https://cdn.collider.com/wp-content/uploads/2020/07/shameless-season-10-thumbnail-171x160.png 171w, https://cdn.collider.com/wp-content/uploads/2020/07/shameless-season-10-thumbnail-321x300.png 321w, https://cdn.collider.com/wp-content/uploads/2020/07/shameless-season-10-thumbnail.png 400w" sizes="(max-width: 171px) 100vw, 171px" title="shameless-season-10-thumbnail" />                <p id="slidertitle">The Top 10 Most Popular TV Shows on Netflix Right Now</p>
            </a>
        </li>
            <li data-tb-region-item>
            <a href="https://collider.com/umbrella-academy-season-2-opening-scene-footage/" rel="bookmark" title="Stop What You&#8217;re Doing &#038; Watch the Incredible &#8216;Umbrella Academy&#8217; Season 2 Opening Scene Right Now" cat="tv">
                <img width="171" height="160" src="https://cdn.collider.com/wp-content/uploads/2020/07/umbrella-academy-aidan-gallagher-thumbnail-171x160.jpg" class="attachment-post-featured size-post-featured" alt="" srcset="https://cdn.collider.com/wp-content/uploads/2020/07/umbrella-academy-aidan-gallagher-thumbnail-171x160.jpg 171w, https://cdn.collider.com/wp-content/uploads/2020/07/umbrella-academy-aidan-gallagher-thumbnail-321x300.jpg 321w, https://cdn.collider.com/wp-content/uploads/2020/07/umbrella-academy-aidan-gallagher-thumbnail.jpg 400w" sizes="(max-width: 171px) 100vw, 171px" title="umbrella-academy-aidan-gallagher-thumbnail" />                <p id="slidertitle">Stop What You&#8217;re Doing &#038; Watch the Incredible &#8216;Umbrella Academy&#8217; Season 2 Opening Scene Right&hellip;</p>
            </a>
        </li>
                        </ul>
                    <div class="clear"><!-- --></div>
                </article>
                    </header>

        <!-- Header Ad -->
				            <div id="cmn_ad_tag_head" class="fw_collider">
            <div class="ad_placeholder" data-nm-id="banner-top"></div>
                <!-- <script type="text/javascript">
                    cmnUNT( '3x3', tile_num++, 0 );
                </script> -->
            </div>
        
<section class="leftpanel">
    
<article id="post-915883" class="post-915883 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment category-features category-tv tag-ellen-page tag-gabriel-ba tag-gerard-way tag-justin-h-min tag-netflix tag-robert-sheehan tag-steve-blackman tag-the-umbrella-academy tag-the-umbrella-academy-season-2 entertainment features tv">

  <!-- .entry-header -->
  <header class="entry-header">

    <h1 class="entry-title">&#8216;The Umbrella Academy&#8217; Season 2: Here&#8217;s What Happened to Ben After That Emotional Scene</h1>

          <h3>
        <span class="byline">by <a href="https://collider.com/author/allie-gemmill/" title="Posts by Allie Gemmill" rel="author">Allie Gemmill</a></span>&nbsp;&nbsp;&nbsp;&nbsp;
        <span class="smltxt"><i class="far fa-clock"></i> August 1, 2020</span>
      </h3>
      
  </header><!-- .entry-header -->

  <!-- .entry-content -->
  <div class="entry-content">

    <div class="clear"></div>
    
<div class="cmplx-meta-top" style="font-size:20px !important;">

    <div class='cmplx-meta cmplx-share'>
    <a target="_blank" class="cmplx-share-link" href="http://www.facebook.com/sharer/sharer.php?m2w&s=100&p[url]=https%3A%2F%2Fcollider.com%2Fumbrella-academy-season-2-ben-death-explained%2F&p[images][0]=https://cdn.collider.com/wp-content/uploads/2020/07/umbrella-academy-season-2-ben-justin-min-slice.jpg&p[title]=&#8216;The Umbrella Academy&#8217; Season 2: Here&#8217;s What Happened to Ben After That Emotional Scene&p[summary]=">
        <span class="cmplx-share-icon facebook share-top">
            <i class="fab fa-facebook-f"></i> <span class="cmplx-icon-title">SHARE</span>
        </span>
    </a>
    <a target="_blank" class="cmplx-share-link" href="https://twitter.com/intent/tweet?original_referer=https%3A%2F%2Fcollider.com%2Fumbrella-academy-season-2-ben-death-explained%2F&text=%26%238216%3BThe+Umbrella+Academy%26%238217%3B+Season+2%3A+Here%26%238217%3Bs+What+Happened+to+Ben+After+That+Emotional+Scene&tw_p=tweetbutton&url=https%3A%2F%2Fcollider.com%2Fumbrella-academy-season-2-ben-death-explained%2F&via=collider" >
        <span class="cmplx-share-icon twitter share-top">
            <i class="fab fa-twitter"></i> <span class="cmplx-icon-title">TWEET</span>
        </span>
    </a>
</div>

</div>
    <div class="clear"></div>

    <p><img class="aligncenter wp-image-915889 size-full" title="umbrella-academy-season-2-ben-justin-min" src="https://cdn.collider.com/wp-content/uploads/2020/07/umbrella-academy-season-2-ben-justin-min-slice.jpg" alt="umbrella-academy-season-2-ben-justin-min" width="600" height="200" srcset="https://cdn.collider.com/wp-content/uploads/2020/07/umbrella-academy-season-2-ben-justin-min-slice.jpg 600w, https://cdn.collider.com/wp-content/uploads/2020/07/umbrella-academy-season-2-ben-justin-min-slice-500x167.jpg 500w" sizes="(max-width: 600px) 100vw, 600px" /></p>
<p><i>[Editor&#8217;s note: The following contains </i><span style="color: #ff0000;"><b><i>spoilers</i></b></span><i> for </i><strong><a href="http://collider.com/tag/the-umbrella-academy/" target="_blank" rel="noopener noreferrer">The Umbrella Academy</a> </strong>Season 2<i>.]</i></p>
<p>We need to talk about Ben Hargreeves&#8217; arc in <strong><em>The Umbrella Academy </em></strong>Season 2. The Netflix series adapted from the <strong>Gerard Way</strong>&#8211;<strong>Gabriel Bá </strong>Dark Horse Comics series is back for another chapter, and while there is more than plenty to discuss about the events of Season 2, we need to dedicate some space to the character of Ben (<strong>Justin H. Min</strong>) and his very heavy and impactful final moments in the penultimate Season 2 episode, &#8220;743.&#8221; After a season spent once again living in the shadow of Klaus (<strong>Robert Sheehan</strong>), with occasional bouts of assuming a physical form through possessing his brother&#8217;s body, Ben emerged — on his own — as one of the big heroes of Season 2.</p>
<p>So, let&#8217;s dig into Ben&#8217;s actual death, his last words to Klaus, and what his reappearance at the end of Season 2 means for the future of <em>The Umbrella Academy.</em></p>
<h2>What Happens to Ben in &#8220;743&#8221;?</h2>
<div class="ad_placeholder rightrail"><div id="Collider_F_M300x250_Incontent_1-1"> </div></div><div data-index="1" id="attachment_916493" class="wp-caption feed alignright" style="max-width: 370px;"><a href="https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-vanya-01.png" target="_blank" rel="noopener noreferrer"><img class="wp-image-916493" title="umbrella-academy-season-2-ben-vanya" src="https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-vanya-01.png" alt="umbrella-academy-season-2-ben-vanya" width="360" height="184" srcset="https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-vanya-01.png 600w, https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-vanya-01-500x255.png 500w" sizes="(max-width: 360px) 100vw, 360px" /></a><p class="wp-caption-text feed">Image via Netflix</p></div>
<p>Ben achieves some unusual new milestones over the course of his Season 2 arc. In addition to successfully possessing Klaus&#8217; body for a brief spell to enjoy the pleasures of taking on a corporeal presence, Ben also manages to go inside the mind of his sister, Vanya. Ben is able to do this when he and Klaus, Allison (<strong>Emmy</strong> <strong>Raver-Lampman</strong>), and Diego (<strong>David</strong> <strong>Castaneda</strong>) go down to the FBI building at the edge of Dealey Plaza to rescue Vanya (<strong>Ellen</strong> <strong>Page</strong>), who is being held there on suspicion she is a Soviet spy. When the potent combination of a truth serum and electrocution device activates Vanya&#8217;s powers and simultaneously knocks her unconscious, Ben is able to get to her when the other siblings cannot and possess her body in a similar manner to Klaus.</p>
<p>Rather than take over Vanya&#8217;s body and move it around in the real world as he did with Klaus, Ben instead goes deep into Vanya&#8217;s mind to find her and bring her back into herself. He finds Vanya, curled up and afraid inside of the mental manifestation of her white violin, hiding from the truth about who she is, what&#8217;s been done to her, and what she has done in the past. Ben and Vanya go on to have a heart-to-heart.</p>
<div class="ad_placeholder rightrail"><div id="Collider_F_M300x250_Incontent_1-2"> </div></div><div data-index="2" id="attachment_916491" class="wp-caption feed alignright" style="max-width: 370px;"><a href="https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-03.png" target="_blank" rel="noopener noreferrer"><img class="wp-image-916491" title="umbrella-academy-season-2-ben" src="https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-03.png" alt="umbrella-academy-season-2-ben" width="360" height="227" srcset="https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-03.png 600w, https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-03-476x300.png 476w" sizes="(max-width: 360px) 100vw, 360px" /></a><p class="wp-caption-text feed">Image via Netflix</p></div>
<p>Ben implores Vanya to keep fighting, acknowledging she has every right to be angry about their father treating her like a bomb and keeping her drugged (an extremely fucked thing to do) her entire life to prevent her from fulfilling her true potential. Ben reminds her of one important thing, too, when he tells Vanya, &#8220;You&#8217;re not a monster. You&#8217;re my sister.&#8221; As the two stand-up, Ben begins to disintegrate as a result of being inside Vanya&#8217;s mind. Although it was good and right and necessary for Ben to reach out to Vanya to help her feel less alone and make peace with the past, his journey into a place he as a ghost has no place to exist immediately has an effect on him. Ben&#8217;s actions help stop Vanya from causing the apocalyptic event we see at the beginning of Season 2, making him even more important to this season&#8217;s events than we may have realized.</p>
<h5>Why Is Ben Finally Passing On After 17 Years of Ghost Life?</h5>
<p>As Ben&#8217;s physical form (whatever that might mean when it comes to also existing within someone&#8217;s mind) disintegrates, he acknowledges it&#8217;s partly down to Vanya&#8217;s powers. But reassures her, saying, &#8220;I died 17 years ago. All the rest of this, these years with Klaus, it&#8217;s all be gravy. At least this time I get to say goodbye.&#8221;</p>
<p>Ben makes one final request of Vanya: To be hugged as he goes. This is the first time Ben has been touched by another person since his death, making his good-bye with Vanya even more poignant. When Min spoke with Collider&#8217;s <strong>Christina Radish </strong>about this scene in particular, he touched on how emotional it was to film, revealing,</p>
<div class="ad_placeholder rightrail"><div id="Collider_F_M300x250_Incontent_1-3"> </div></div><div data-index="3" id="attachment_916489" class="wp-caption feed alignright" style="max-width: 370px;"><a href="https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-vanya-02.png" target="_blank" rel="noopener noreferrer"><img class="wp-image-916489" title="umbrella-academy-season-2-ben-vanya" src="https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-vanya-02-600x341.png" alt="umbrella-academy-season-2-ben-vanya" width="360" height="204" srcset="https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-vanya-02-600x341.png 600w, https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-vanya-02-768x436.png 768w, https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-vanya-02-1536x872.png 1536w, https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-vanya-02-2048x1162.png 2048w, https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-vanya-02-765x434.png 765w, https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-vanya-02-500x284.png 500w, https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-vanya-02-900x511.png 900w" sizes="(max-width: 360px) 100vw, 360px" /></a><p class="wp-caption-text feed">Image via Netflix</p></div>
<blockquote><p>&#8220;When I shot that final scene with Ellen Page and Vanya in Episode 9, I actually thought that was my final scene on the show. It was quite an emotional scene because Ben is saying goodbye to his family, but Justin, as the actor, I felt like I was saying goodbye to the show, as well, and my actual crew family that I’ve grown to love and care for, for the past six months, and even some of our continuing crew members, for the last two years.&#8221;</p></blockquote>
<p>Essentially, <em>The Umbrella Academy </em>is trying to tell us Ben is finally able to pass on in part because he was able to get through to at least one of his siblings (Klaus has always been combative in taking Ben&#8217;s advice.) and in part because Vanya&#8217;s destructive side is tearing at the fabric of his very existence. It&#8217;s a bittersweet ending for Ghost Ben, but one which has to happen in order to get Vanya to the stable place she needs to be for the final battle at the end of Season 2.</p>
<h2>Why Is Ben&#8217;s Message For Klaus Important?</h2>
<p>The Season 2 finale of <em>The Umbrella Academy </em>opens with Ben&#8217;s funeral in 2006: We learn Ben died in an accident during an Umbrella Academy mission, and the fractures in every Umbrella Academy relationship begin to show themselves during this funeral scene as every teenaged Hargreeves family member snaps at each other before storming off. The last one left is Klaus, who takes a moment to process near Ben&#8217;s casket and attempts to use his powers. Suddenly, it&#8217;s revealed Ben is with Klaus. Able to connect with the dead, Klaus helps Ben adjust to his new life as a ghost (at least, that&#8217;s what Klaus believes at the time).</p>
<p>Ben&#8217;s departure with Vanya sees him leaving a message for Klaus, which Vanya dutifully passes along in Episode 10. She tells Klaus, &#8220;He wanted me to tell you that he was too scared to go to the light. It wasn&#8217;t you that made him stay,&#8221; which causes Klaus to reply in astonishment, &#8220;All these years and I thought it was my fault that he didn&#8217;t take his ticket to heaven.&#8221;</p>
<div class="ad_placeholder rightrail"><div id="Collider_F_M300x250_Incontent_1-4"> </div></div><div data-index="4" id="attachment_916488" class="wp-caption feed alignright" style="max-width: 370px;"><a href="https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-klaus-01.png" target="_blank" rel="noopener noreferrer"><img class="wp-image-916488" title="umbrella-academy-season-2-ben-klaus" src="https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-klaus-01.png" alt="umbrella-academy-season-2-ben-klaus" width="360" height="234" srcset="https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-klaus-01.png 600w, https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-klaus-01-462x300.png 462w" sizes="(max-width: 360px) 100vw, 360px" /></a><p class="wp-caption-text feed">Image via Netflix</p></div>
<p>Ben&#8217;s message for Klaus hits hard because it&#8217;s the one good-bye that needed to happen, but it would have been the same if it had happened directly. Ben has been the one person keeping Klaus tied to the world of the living for 17 years, the one who has been a moral compass, a confidant, a good friend, and brother. Klaus also likely believes he summoned Ben with his powers the day of the funeral, so there must have been some fraternal feeling of responsibility in looking out for Ben all these years. Through Klaus, Ben has been able to find some acceptance of his death while still being able to see his brothers and sisters grow up into the superheroes they are today. Seeing the world and living this adventure through Klaus&#8217; eyes has almost been like a final hurrah for Ben as he mourns his circumstance and gathers the strength to tackle his next big adventure alone.</p>
<h2>Will Ben Return For<em> </em>Season 3?</h2>
<p>In the shocking cliffhanger Season 2 ending, it is revealed a new team, The Sparrow Academy, exists in what appears to be an alternate timeline. Not only this, but Ben — well, a new Ben — is alive in this timeline and he appears to be the leader of this new superhero group. The season ends with this news, leaving us to wonder what will happen in Season 3 and how Sparrow Academy Ben will play into the action.</p>
<p>We may not know much about Sparrow Academy Ben&#8217;s specific arc, but if Season 3 happens, Min will return as the Sparrow Academy version of Ben. (At time of publication, <em>The Umbrella Academy </em>still has not been renewed.) During Christina Radish of Collider&#8217;s chat with Min about Ben&#8217;s arc in Season 2, the actor made time to touch on the reveal of Sparrow Academy Ben and his excitement about coming back.</p>
<div class="ad_placeholder rightrail"><div id="Collider_F_M300x250_Incontent_1-5"> </div></div><div data-index="5" id="attachment_916496" class="wp-caption feed alignright" style="max-width: 370px;"><a href="https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-klaus-ghost-ben.png" target="_blank" rel="noopener noreferrer"><img class="wp-image-916496" title="umbrella-academy-season-2-klaus-ghost-ben" src="https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-klaus-ghost-ben-600x366.png" alt="umbrella-academy-season-2-klaus-ghost-ben" width="360" height="220" srcset="https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-klaus-ghost-ben-600x366.png 600w, https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-klaus-ghost-ben-768x469.png 768w, https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-klaus-ghost-ben-1536x938.png 1536w, https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-klaus-ghost-ben-2048x1250.png 2048w, https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-klaus-ghost-ben-765x467.png 765w, https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-klaus-ghost-ben-491x300.png 491w, https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-klaus-ghost-ben-900x550.png 900w" sizes="(max-width: 360px) 100vw, 360px" /></a><p class="wp-caption-text feed">Image via Netflix</p></div><div class="ad_placeholder mb15"><div id="Collider_F_M300x250_Incontent_2-5"> </div></div>
<blockquote><p>&#8220;We’d received the draft of Episode 10, at that point, when I shot that scene with Ellen, but the last three pages had been omitted, so none of us knew. And then, a few weeks after that, um, I got a ping on my phone, for a top secret email from Steve Blackman, who had just emailed the seven Hargreeves children and said, &#8216;Here’s the last scene. Hope you enjoy it.&#8217; I remember it vividly. It feels like yesterday. It was 8:48pm in my Toronto apartment, and I read it and just started screaming at the top of my lungs in there. I was completely shocked and flabbergasted and gobsmacked and overjoyed, to be allowed to come back and be a part of this show, especially if we get renewed for another season.&#8221;</p></blockquote>
<p>Min also alluded to the fact that Sparrow Academy Ben will be entirely different from Ghost Ben, especially in regard to his role within the alternate timeline superhero team. This new Ben will look and operate in a different headspace to Ghost Ben and, most importantly, will be a living, breathing human being people will have to listen to. According to Min,</p>
<div class="ad_placeholder rightrail"><div id="Collider_F_M300x250_Incontent_1-6"> </div></div><div data-index="6" id="attachment_916486" class="wp-caption feed alignright" style="max-width: 370px;"><a href="https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-sparrow-academy.png" target="_blank" rel="noopener noreferrer"><img class="wp-image-916486" title="umbrella-academy-season-2-ben-sparrow-academy" src="https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-sparrow-academy.png" alt="umbrella-academy-season-2-ben-sparrow-academy" width="360" height="206" srcset="https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-sparrow-academy.png 600w, https://cdn.collider.com/wp-content/uploads/2020/08/umbrella-academy-season-2-ben-sparrow-academy-500x286.png 500w" sizes="(max-width: 360px) 100vw, 360px" /></a><p class="wp-caption-text feed">Image via Netflix</p></div><div class="ad_placeholder mb15"><div id="Collider_F_M300x250_Incontent_2-6"> </div></div>
<blockquote><p>&#8220;My character is not in the comic books, at all, so I had free reign to build Ghost Ben from the ground up, and do whatever I wanted to with him. And then, here we are, at the end of Season 2, and I literally get to do it, all over again, with another character who’s brand new and that I get to build, from the ground up. How many times does an actor get to play two completely different characters, on the same show? Even from his appearance to the scar on his face to his hair, we wanted Sparrow Academy Ben to feel completely different from Ghost Ben. I even grew out what I could of my incredible mustache, so he could seem a bit rougher. We had about 20 iterations of that hair that we were experimenting with. We just really wanted to make it messier and longer, and there’s even a couple of blue streaks. In that lighting, I don’t think you can really see it, but hopefully, you’ll be able to see that better, in a next season. I’m so excited.&#8221;</p></blockquote>
<p>And there you have it. Season 2 officially put an end to Ghost Ben, but a new Ben is on the way, and he will be a force to be reckoned with as the leader of the Sparrow Academy team. (Take that, Luther!). We may not know what the future holds for The Umbrella Academy, but we do know that the chances are very good Ben will not be out of the picture if a new season ends up happening.</p>
<p><em>The Umbrella Academy </em>Seasons 1 and 2 are now available to stream on Netflix. For more, check out our <a href="https://collider.com/umbrella-academy-season-2-review/" target="_blank" rel="noopener noreferrer">review of <em>The Umbrella Academy </em></a><a href="https://collider.com/umbrella-academy-season-2-review/" target="_blank" rel="noopener noreferrer">Season 2</a> and our in-depth <a href="https://collider.com/the-umbrella-academy-season-2-ending-explained-netflix/" target="_blank" rel="noopener noreferrer">explainer on the Season 2 ending</a>.</p>
<p><em>Allie Gemmill is the Weekend Contributing Editor for Collider. You can follow them on Twitter <a href="https://twitter.com/_matineeidle" target="_blank" rel="noopener noreferrer">@_matineeidle</a>.</em></p>
      <div id="" class="ad_placeholder feed-mid">
                  <div id="Collider_F_M320x50_Mid-1"></div>
      </div>
  <script type='application/ld+json'>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</script><div class="opt related-content"><div id="related-content-title">Related Content</div><ul><li><a href="https://collider.com/best-new-movies-on-netflix-august-2020/" alt="https://cdn.collider.com/wp-content/uploads/2020/07/project-power-joseph-gordon-levitt-slice.jpg">The Best New Movies on Netflix in August 2020</a> </li> <li><a href="https://collider.com/star-wars-skywalker-saga-movie-titles-tiktok/" alt="https://cdn.collider.com/wp-content/uploads/2020/08/star-wars-the-last-jedi-mark-hamill-luke-slice.jpg">Viral 'Star Wars' TikTok Pitches New Titles for Skywalker Saga Movies That Actually Work</a> </li> <li><a href="https://collider.com/new-to-hulu-in-august-2020/" alt="https://cdn.collider.com/wp-content/uploads/2020/07/the-peanut-butter-falcon-slice.jpg">Here's What's Coming to Hulu in August 2020</a> </li> <li><a href="https://collider.com/fargo-season-4-teaser-trailer-release-date-update/" alt="https://cdn.collider.com/wp-content/uploads/2020/08/fargo-season-4-jason-schwartzman-slice.png">FX's 'Fargo' Gives Us a New Season 4 Teaser, But What About a Release Date?</a> </li> <li><a href="https://collider.com/callum-turner-the-capture-interview-fantastic-beasts-2/" alt="https://cdn.collider.com/wp-content/uploads/2020/07/the-capture-peacock-callum-turner-slice.jpg">Callum Turner on His Peacock Series 'The Capture' and Why He’ll Only Appear in Season 1</a> </li> </ul></div>	</div>  <!-- .entry-content -->

</article>

<!-- Pagination and widgets -->

<div id="after-post-stuff">

    <div class="newsletter_signup" style="text-align:center;padding:0 15px;margin:2em 0;max-width:100%;height:auto;">
	<a href="https://collider.com/newsletter">
		<img src="https://collider.com/wp-content/themes/collider-v3/images/collider-newsletter.png" alt="Click to sign up for the Collider email newsletter, with news, features, and giveaways.">
	</a>
</div>
	    <!-- Next / Previous Posts -->
    <div class="pagealignleft">
                        <div class="top">
                    <a href="https://collider.com/fargo-season-4-teaser-trailer-release-date-update/">
                        <i class="fa fa-chevron-left"></i>
                        <span>Previous Article</span>
                    </a>
                </div>
                <div class="bottom">
                    <a href="https://collider.com/fargo-season-4-teaser-trailer-release-date-update/">
                                        <span>FX's 'Fargo' Gives Us a New Season 4 Teaser, But What About&hellip;</span>
                    </a>
                </div>
            </div>
    <div class="pagealignright">
                <div class="top">
            <a href="https://collider.com/new-to-hulu-in-august-2020/">
                <span>Next Article</span>
                <i class="fa fa-chevron-right"></i>
            </a>
        </div>
        <div class="bottom">
            <a href="https://collider.com/new-to-hulu-in-august-2020/">
                <span>Here's What's Coming to Hulu in August 2020</span>
                            </a>
        </div>
            </div>

    <div class="clear"></div>



<div class="cmplx-meta-bottom">
    <div class='cmplx-meta cmplx-share'>
    <a target="_blank" class="cmplx-share-link" href="http://www.facebook.com/sharer/sharer.php?m2w&s=100&p[url]=https%3A%2F%2Fcollider.com%2Fumbrella-academy-season-2-ben-death-explained%2F&p[images][0]=https://cdn.collider.com/wp-content/uploads/2020/07/umbrella-academy-season-2-ben-justin-min-slice.jpg&p[title]=&#8216;The Umbrella Academy&#8217; Season 2: Here&#8217;s What Happened to Ben After That Emotional Scene&p[summary]=">
        <span class="cmplx-share-icon facebook share-bottom">
            <i class="fab fa-facebook-f"></i> <span class="cmplx-icon-title">SHARE</span>
        </span>
    </a>
    <a target="_blank" class="cmplx-share-link" href="https://twitter.com/intent/tweet?original_referer=https%3A%2F%2Fcollider.com%2Fumbrella-academy-season-2-ben-death-explained%2F&text=%26%238216%3BThe+Umbrella+Academy%26%238217%3B+Season+2%3A+Here%26%238217%3Bs+What+Happened+to+Ben+After+That+Emotional+Scene&tw_p=tweetbutton&url=https%3A%2F%2Fcollider.com%2Fumbrella-academy-season-2-ben-death-explained%2F&via=collider" >
        <span class="cmplx-share-icon twitter share-bottom">
            <i class="fab fa-twitter"></i> <span class="cmplx-icon-title">TWEET</span>
        </span>
    </a>
    <a class="cmplx-share-link" >
        <span class="cmplx-share-icon messenger share-bottom">
            <i class="fab fa-facebook-messenger"></i> <span class="cmplx-icon-title">CHAT</span>
        </span>
    </a>

</div>
</div>

    <!-- Tags -->
            <div class="mytags">
            <h5>Tags</h5> • <a href="https://collider.com/tag/ellen-page/" rel="tag">Ellen Page</a> • <a href="https://collider.com/tag/gabriel-ba/" rel="tag">GABRIEL BÁ</a> • <a href="https://collider.com/tag/gerard-way/" rel="tag">Gerard Way</a> • <a href="https://collider.com/tag/justin-h-min/" rel="tag">Justin H. Min</a> • <a href="https://collider.com/tag/netflix/" rel="tag">Netflix</a> • <a href="https://collider.com/tag/robert-sheehan/" rel="tag">Robert Sheehan</a> • <a href="https://collider.com/tag/steve-blackman/" rel="tag">Steve Blackman</a> • <a href="https://collider.com/tag/the-umbrella-academy/" rel="tag">The Umbrella Academy</a> • <a href="https://collider.com/tag/the-umbrella-academy-season-2/" rel="tag">the umbrella academy season 2</a><br>        </div>
    
</div> <!-- #after-post-stuff -->

<!-- In Content Suitcase Unit -->
<div class="in-content-ad" style="border-bottom:1px solid #bdbdbd">
        <!-- 728 x 90 BTF Desktop -->
    <div data-pw-desk="leaderboard_btf"></div>
    <!-- 320 x 50 BTF Mobile -->
    <div data-pw-mobi="leaderboard_btf"></div>
</div>

<div id="rc-widget-81022f" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="142970"></div>


<!-- Spot.IM Conversation Module -->

<div id="vuukle-comments"></div><script>var VUUKLE_CONFIG = {apiKey: 'bfe68294-1ccf-4152-99cb-4568ac7ac0d5',articleId: '1',comments: {enabled: false}};(function() {var d = document,s = d.createElement('script');s.async = true;s.src = 'https://cdn.vuukle.com/platform.js';(d.head || d.body).appendChild(s);})();</script>	
<div id="article-comments" class="article-comments-container text-center">
	<div id="comments">
  <script async src="https://launcher.spot.im/spot/sp_Qf5Kf2mr"
      data-spotim-module="spotim-launcher"
      data-post-id="915883"
      data-post-url="https://collider.com/umbrella-academy-season-2-ben-death-explained/"
      data-facebook-url="https://collider.com/umbrella-academy-season-2-ben-death-explained/"></script>
	</div>
</div>  <!-- Newsfeed w/ Infinite Scroll -->

  <div id="latest-news" class="tv">
    <h3 id="latest-news-header" class="heading-font archive-title">
      <span>Television</span>
    </h3>

    <i id="infscr-loading" class="fas fa-2x fa-spin fa-circle-notch"></i>
  </div>

  <script type="text/javascript" src="/wp-content/themes/collider-v3/js/infinite-newsfeed-single.js?v=201710251625"></script>
    <script type="text/javascript">
    jQuery(document).ready(function($) {
        var spinnerId = '#infscr-loading',
        contentDiv = '#content',
        latestNewsId = '#latest-news',
        postIdentifier = 'article',
        mode = 'desktop',
        url = '/page/';

                    url = '/tv/page/';
        
        infiniteNewsfeed(spinnerId,contentDiv,postIdentifier,latestNewsId,mode,url);
    });
    </script>

    
            <div class="clear"><!-- --></div>

        
            <div class="clear" style="height:15px;"></div>
    </section>


    <aside class="rightpanel">

        <div class="rightpanel_displayonfloat">

            <aside class="rightrail-ad contentad">
              <aside id="text-26" class="widget widget_text">
                                <div data-pw-desk="med_rect_atf"></div>
                <div data-pw-mobi="med_rect_atf"></div>
              </aside>
            </aside>

            <!-- BEST MOVIES ON NETFLIX -->
            <aside class="rightrail-netflix">
              <a class="netflix-link" href="/best-movies-on-netflix-streaming/"><span class="rightrail-netflix__text">BEST MOVIES ON NETFLIX</span></a>
            </aside>

            <div id="rc-widget-27bb38" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="142971"></div>

        </div> <!-- .rightpanel_displayonfloat -->

        <!-- Our Staff -->
        <aside class="our-staff ">
            <aside id="text-25" class="widget widget_text">
                <h3 class="widget-title"><span>Our Staff</span></h3>

                <div class="textwidget">
                    <ul class="staff-list">
                      <li>
                        <div>
                          <a href="https://collider.com/author/steve-weintraub/" class="staff-name">Steve "Frosty" Weintraub</a>
                        </div>
                        <span class="staff-title">Editor in Chief</span> | <a href="http://twitter.com/colliderfrosty" target="_blank">@colliderfrosty</a>
                      </li>
                      <li><div><a href="https://collider.com/author/adam-chitwood/" class="staff-name">Adam Chitwood</a></div><span class="staff-title">Managing Editor</span> | <a href="http://www.twitter.com/adamchitwood" target="_blank">@adamchitwood</a></li>
                      <li><div><a href="https://collider.com/author/matt-goldberg/" class="staff-name">Matt Goldberg</a></div><span class="staff-title">Senior Editor, Film</span> | <a href="http://twitter.com/MattGoldberg" target="_blank">@MattGoldberg</a></li>
                      <li>
                        
<div>
  <a href="https://collider.com/author/dave-trumbore/" class="staff-name">Dave Trumbore</a>
</div>
<span class="staff-title">Senior Editor, Games</span> | <a href="http://twitter.com/DrClawMD" target="_blank">@DrClawMD</a>                      </li>
                      <li><div><a href="https://collider.com/author/perri-nemiroff/" class="staff-name">Perri Nemiroff</a></div><span class="staff-title">Content Development Editor</span> | <a href="https://twitter.com/PNemiroff" target="_blank">@PNemiroff</a></li>
                      <li><div><a href="https://collider.com/author/haleigh-foutch/" class="staff-name">Haleigh Foutch</a></div><span class="staff-title">Senior Editor, SEO</span> | <a href="https://twitter.com/HaleighFoutch" target="_blank">@HaleighFoutch</a></li>
                      <li>
                        
<div>
  <a href="https://collider.com/author/jeff-sneider/" class="staff-name">Jeff Sneider</a>
</div>
<span class="staff-title">Senior Film Reporter</span> | <a href="http://twitter.com/TheInSneider" target="_blank">@TheInSneider</a>                      </li>
                      <li><div><a href="https://collider.com/author/vinnie-mancuso/" class="staff-name">Vinnie Mancuso</a></div><span class="staff-title">Senior Editor</span> | <a href="https://twitter.com/VinnieMancuso1" target="_blank">@VinnieMancuso1</a></li>
                      <li>
                        
<div>
  <a href="https://collider.com/author/christina-radish/" class="staff-name">Christina Radish</a>
</div>
<span class="staff-title">Senior Reporter, Film & Television</span> | <a href="http://twitter.com/ChristinaRadish" target="_blank">@ChristinaRadish</a>                      </li>
                      <li>
                        
<div>
  <a href="https://collider.com/author/thomas-reimann/" class="staff-name">Tom Reimann</a>
</div>
<span class="staff-title">Associate Editor</span> | <a href="http://twitter.com/startthemachine" target="_blank">@startthemachine</a>                      </li>
                      <li>
                        
<div>
  <a href="https://collider.com/author/gregory-lawrence/" class="staff-name">Gregory Lawrence</a>
</div>
<span class="staff-title">Associate Editor</span> | <a href="http://twitter.com/SmithLGreg" target="_blank">@SmithLGreg</a>                      </li>
                      <li>
                        
<div>
  <a href="https://collider.com/author/allie-gemmill/" class="staff-name">Allie Gemmill</a>
</div>
<span class="staff-title">Weekend Contributing Editor</span> | <a href="http://twitter.com/_matineeidle" target="_blank">@_matineeidle</a>                      </li>
                      <li>
                        
<div>
  <a href="https://collider.com/author/liz-shannon-miller/" class="staff-name">Liz Shannon Miller</a>
</div>
<span class="staff-title">Senior TV Editor</span> | <a href="http://twitter.com/lizlet" target="_blank">@lizlet</a>                      </li>
                      <li>
                        
<div>
  <a href="https://collider.com/author/drew-taylor/" class="staff-name">Drew Taylor</a>
</div>
<span class="staff-title">Associate Editor</span> | <a href="http://twitter.com/DrewTailored" target="_blank">@DrewTailored</a>                      </li>
                    </ul>
                </div>
            </aside>
        </aside>
        <div id="sidebar_ad_2" class="sidebar_ad" style="margin-top:2em;">
          <div data-pw-desk="med_rect_btf"></div>
          <div data-pw-mobi="med_rect_btf"></div>
        </div>
        <div class="rightpanel-end"></div>
    </aside>

    
    <div class="clear"><!-- --></div>

  </section><!-- end of welcome section -->



  <!-- Typekit Fonts -->
  <script src="https://use.typekit.net/cui2tsb.js"></script>
  <script>try{Typekit.load();}catch(e){}</script>

</div> <!-- closing div for cmn_wrap in header -->

  <!-- <div id="bottom-banner" style="width:100%;background-color:#e0e0e0e7;text-align:center;height:90px;z-index:1000001;position:fixed;bottom:0">
    <div class="ad_placeholder" style="width:728px;height:90px;margin:0 auto;position:relative;">
            <img id="bottom-banner-close-button" style="height:16px;width:16px;position:absolute;left:-20px;top:0;padding:2px;" src="https://collider.com/wp-content/themes/collider-v3/images/close-circle-512.png" alt="Close" />
    </div>
  </div> -->

<div id='Collider_1x1_1'></div>

<script>
  function handleBottomBannerCloseClick() {
    const bottomBannerElem = document.querySelectorAll('#bottom-banner');
    if (bottomBannerElem && bottomBannerElem.length > 0);
    bottomBannerElem[0].style.display = 'none';
  }

  const bottomBannerCloseElem = document.querySelectorAll('#bottom-banner-close-button');
  if (bottomBannerCloseElem && bottomBannerCloseElem.length > 0) {
      const bottomBannerCloseBtn = bottomBannerCloseElem[0];
      bottomBannerCloseBtn.addEventListener('click', handleBottomBannerCloseClick, { passive: false });
  }
</script>

  <!-- CMN BRANDED FOOTER -->
  <footer id="footer">
    <div class="container">
        <div class="row">
            <div class="left-col col-xs-12 col-md-7">
                <div class="row">

                    <div class="footer-icon logo-col col-xs-12 col-md-3">
                        <a href="/" target="_self" ga-link ga-category="Footer" ga-action="Click on footer logo">
                            <img id="collider-footer-logo-image"src="https://collider.com/wp-content/themes/collider-v3/images/Collider_Logo_Light.png"/ alt="Collider.com">
                        </a>
                    </div>

                    <div class="col-md-7">
                        <div class="row">
                            <div class="col-xs-12">
                                <span class="footer-link">
                                    <a href="/about" target="_self" ga-link ga-category="Footer" ga-action="Click on footer navigation">
                                        About Us
                                    </a>
                                </span>
                                <span class="footer-link">
                                    <a href="/contact-us" target="_self" ga-link ga-category="Footer" ga-action="Click on footer navigation">
                                        Contact Us
                                    </a>
                                </span>
                                <span class="footer-link">
                                    <a href="/sitemap.xml" target="_self" ga-link ga-category="Footer" ga-action="Click on footer navigation">
                                        Site Map
                                    </a>
                                </span>
                                <span class="footer-link">
                                    <a href="/collider-privacy-policy" target="_self" ga-link ga-category="Footer" ga-action="Click on footer navigation">
                                        Privacy Policy
                                    </a>
                                </span>
                                <span class="footer-link">
                                    <a href="/terms" target="_self" ga-link ga-category="Footer" ga-action="Click on footer navigation">
                                        Terms And Conditions
                                    </a>
                                </span>
                            </div>
                        </div>
                    </div>
                </div>
            </div>

            <div class="right-col col-xs-12 col-md-4">

                <div class="clearfix visible-xs-block visible-sm-block"></div>

                <ul class="social-container">
                    <li><a href="http://www.facebook.com/collider" target="_blank" rel="nofollow" ga-link ga-category="Main Footer" ga-action="Click on social links" ga-label="Facebook"><i class="fa-icon fab fa-facebook-f"></i></a></li>
                    <li><a href="http://twitter.com/collider" target="_blank" rel="nofollow" ga-link ga-category="Main Footer" ga-action="Click on social links" ga-label="Twitter"><i class="fa-icon fab fa-twitter"></i></a></li>
                    <li><a href="http://www.youtube.com/collidervideos" target="_blank" rel="nofollow" ga-link ga-category="Main Footer" ga-action="Click on social links" ga-label="YouTube"><i class="fa-icon fab fa-youtube"></i></a></li>
                    <li><a href="https://instagram.com/collider/" target="_blank" rel="nofollow" ga-link ga-category="Main Footer" ga-action="Click on social links" ga-label="Instagram"><i class="fa-icon fab fa-instagram"></i></a></li>
                </ul>

            </div>
            <div class="col-xs-12 col-md-12">
                <div class="row">
                    <div class="copyright-col col-xs-9 col-xs-offset-1 col-sm-8 col-sm-offset-2 center">
                        <span class="copyright">COLLIDER participates in various affiliate marketing programs, which means COLLIDER gets paid commissions on purchases made through our links to retailer sites. Our editorial content is not influenced by any commissions we receive.</span>
                    </div>
                    <div class="copyright-col col-xs-12 center">
                        <span class="copyright">&copy; 2020 Collider Cryptomedia, Inc. All Rights Reserved.</span>
                    </div>
                </div>
            </div>
        </div>
    </div>
</footer>
  <!-- end CMN BRANDED FOOTER -->


  <script type="text/javascript">
  	// cmnUNT('tover', tile_num++);
  </script>

  <!-- WP Footer Scripts -->
  <script src='https://collider.com/wp-content/themes/collider-v3/dist/js/collider.min.js?ver=2019_08_09_01'></script>
<script src='https://collider.com/wp-includes/js/wp-embed.min.js?ver=5.4.1'></script>
<script src='https://assets.revcontent.com/master/delivery.js?ver=5.4.1'></script>



  <!-- Google Tag Manager | DataLayer Variables -->
  <script type="text/javascript">
      window.Complex = window.Complex || {};
      window.Complex.complexDataLayer = window.Complex.complexDataLayer || [];
      window.Complex.comScoreFireTag = function(event) {
          window.Complex.complexDataLayer.push({'event': event});
      };
  </script>

</body>
</html>

<!-- Performance optimized by Redis Object Cache. Learn more: https://wprediscache.com -->
