<!DOCTYPE html>
<html lang="en-US">
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
    <meta name="viewport" content="user-scalable=yes, initial-scale=1.0, width=device-width"/>

    <link rel="preconnect" href="https://static1.colliderimages.com">

                            <link rel="preconnect" href="https://www.google-analytics.com">
            
        
    <link rel="preload"
                      media="(max-width: 480px)"
                      href="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/01/young-rock-banner.png?q=50&fit=contain&w=480&h=300&dpr=1.5" importance="high"  as="image"><link rel="preload"
                      media="(min-width: 481px) and (max-width: 767px)"
                      href="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/01/young-rock-banner.png?q=50&fit=contain&w=767&h=450&dpr=1.5" importance="high"  as="image"><link rel="preload"
                      media="(min-width: 768px) and (max-width: 1023px)"
                      href="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/01/young-rock-banner.png?q=50&fit=contain&w=943&h=500&dpr=1.5" importance="high"  as="image"><link rel="preload"
                      media="(min-width: 1024px)"
                      href="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/01/young-rock-banner.png?q=50&fit=contain&w=750&h=375&dpr=1.5" importance="high"  as="image">
    
    <script>
        // GLOBAL JS VARIABLES FOR THE PAGE
        var VALNET_GLOBAL_FBAPPID = "172826243054377";
        // GLOBAL JS VARIABLES FOR GOOGLE ANALYTICS
                    var VALNET_GLOBAL_GOOGLEANALYTICSPROPERTYID = "UA-35624077-21";
            var VALNET_GLOBAL_POSTID = "2014242";
            var VALNET_GLOBAL_AUTHOR = "aidan-kelley";
            var VALNET_GLOBAL_CHANNEL = "tv";
            var VALNET_GLOBAL_VIEW = "regular";
            var VALNET_GLOBAL_EXACTVIEW = "all";
            var VALNET_GLOBAL_ISPREMIUM = "false";
            var VALNET_GLOBAL_ENVIRONMENT = "native";
            var VALNET_GLOBAL_POSTTYPE = "article";
            var VALNET_GLOBAL_JREDITOR = "";
            var VALNET_GLOBAL_SREDITOR = "remus-noronha";
            var VALNET_GLOBAL_NUMBERPERPAGE = "all";
            var VALNET_GLOBAL_ISENGAGEMENTTEST = "false";
            var VALNET_GLOBAL_DETECTEDDEVICE = "desktop";
            var VALNET_GLOBAL_IPADDRESS = "107.23.218.4";
            var VALNET_GLOBAL_BROWSERUSERAGENT = "CCBot\/3.0\u0020\u0028https\u003A\/\/commoncrawl.org\/faq\/\u003B\u0020info\u0040commoncrawl.org\u0029";
            var VALNET_GLOBAL_LENGTH = "20-24";
            var VALNET_GLOBAL_DATEPUBLISHED = "20220314";
            var VALNET_GLOBAL_EDITOR = "";
            var VALNET_GLOBAL_POSTPAYMENTCATEGORY = "resource";
            var VALNET_GLOBAL_CATEGORY = "tv-features";
            var VALNET_GLOBAL_TAGS = "|dwayne-the-rock-johnson|young-rock|peacock|";
            var VALNET_GLOBAL_ISFACEBOOKBROWSER = "R";
            var VALNET_GLOBAL_ADS = "BOT";
            var VALNET_GLOBAL_AMPTRAFFIC = "false";
            var VALNET_GLOBAL_TEMPLATE = "content-all";
            var VALNET_GLOBAL_TLDRPERMALINK = "/young-rock-season-2-release-date-cast-trailer-dwayne-johnson/";
            var VALNET_GLOBAL_TLDRPAGE = "1";
            var VALNET_GLOBAL_TLDRTOTALNUMPAGE = "0";
            var VALNET_GLOBAL_TLDRVIEWTYPE = "";
            var VALNET_GLOBAL_ISADBLOCK = true;
            var VALNET_GLOBAL_NETWORKCATEGORY = "television";
            var VALNET_GLOBAL_CONTENTTYPE = "Resource";
            var VALNET_GLOBAL_INTENT = "Evergreen";
            </script>

    <script> window.arrayOfEmbeds = [] </script>
    
            
    
                    
                <link rel="stylesheet" href="/public/build/a-article.c7d212e0.css">
        
    <!-- Google Analytics -->
<script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
</script>
<!-- End Google Analytics -->
        <!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
            new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,'script','dataLayer','GTM-M3N97VF');</script>
<!-- End Google Tag Manager -->
    <meta name="robots" content="max-image-preview:large">
    <script type="text/javascript">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</script>
    <script type="text/javascript">
        /*!
            Waypoints Inview Shortcut - 4.0.1
            Copyright © 2011-2016 Caleb Troughton
            Licensed under the MIT license.
            https://github.com/imakewebthings/waypoints/blob/master/licenses.txt
        */
        !function(){"use strict";function t(){}function e(t){this.options=i.Adapter.extend({},e.defaults,t),this.axis=this.options.horizontal?"horizontal":"vertical",this.waypoints=[],this.element=this.options.element,this.createWaypoints()}var i=window.Waypoint;e.prototype.createWaypoints=function(){for(var t={vertical:[{down:"enter",up:"exited",offset:"100%"},{down:"entered",up:"exit",offset:"bottom-in-view"},{down:"exit",up:"entered",offset:0},{down:"exited",up:"enter",offset:function(){return-this.adapter.outerHeight()}}],horizontal:[{right:"enter",left:"exited",offset:"100%"},{right:"entered",left:"exit",offset:"right-in-view"},{right:"exit",left:"entered",offset:0},{right:"exited",left:"enter",offset:function(){return-this.adapter.outerWidth()}}]},e=0,i=t[this.axis].length;i>e;e++){var n=t[this.axis][e];this.createWaypoint(n)}},e.prototype.createWaypoint=function(t){var e=this;this.waypoints.push(new i({context:this.options.context,element:this.options.element,enabled:this.options.enabled,handler:function(t){return function(i){e.options[t[i]].call(e,i)}}(t),offset:t.offset,horizontal:this.options.horizontal}))},e.prototype.destroy=function(){for(var t=0,e=this.waypoints.length;e>t;t++)this.waypoints[t].destroy();this.waypoints=[]},e.prototype.disable=function(){for(var t=0,e=this.waypoints.length;e>t;t++)this.waypoints[t].disable()},e.prototype.enable=function(){for(var t=0,e=this.waypoints.length;e>t;t++)this.waypoints[t].enable()},e.defaults={context:window,enabled:!0,enter:t,entered:t,exit:t,exited:t},i.Inview=e}();
    </script>

                
    <script async src="/public/build/dfp.js"></script>
            <script async src="/public/build/valnet-header-ads.929bb40d.js"></script>
    
    

    
    
    
    
                
    

    	
	    	    	        <link rel="amphtml" href="https://collider.com/young-rock-season-2-release-date-cast-trailer-dwayne-johnson/amp/" />
	    
	    	        <link rel="canonical" href="https://collider.com/young-rock-season-2-release-date-cast-trailer-dwayne-johnson/" />
	    
	    	    	        
	        	    
	    <title>Young Rock Season 2: Release Date, Trailer, &amp; Everything You Need to Know </title>
	    
	    	        	        <meta name="description" content="Here's everything we know so far about Dwayne Johnson's Young Rock Season 2, including updates on the release date, trailer, cast, and more." />
	    	    
	    	
        
        
            <meta property="og:title" content="‘Young Rock’ Season 2: Release Date, Trailer, Cast, and Everything You Need to Know"/>
    <meta property="og:type" content="article"/>

            <meta property="og:image" content="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/01/young-rock-banner.png"/>
                    <meta property="og:image:width" content="1400"/>
            <meta property="og:image:height" content="700"/>
                    

                                                <meta property="og:url" content="https://collider.com/young-rock-season-2-release-date-cast-trailer-dwayne-johnson/"/>
                        
    <meta property="og:locale" content="en_US"/>
    <meta property="og:description" content="Young Rock is back in the kitchen and cooking up a storm."/>

            <meta property="og:site_name" content="Collider"/>
    
                        <meta property="article:published_time" content="2022-03-14T15:15:14Z"/>
                            <meta property="article:modified_time" content="2022-03-14T15:15:14Z"/>
                                        <meta property="article:section" content="TV Features"/>
            


    

            <meta name="twitter:card" content="summary_large_image">
                <meta name="twitter:site" content="@collider">
        <meta name="twitter:title" content="‘Young Rock’ Season 2: Release Date, Trailer, Cast, and Everything You Need to Know">
        <meta name="twitter:description" content="Young Rock is back in the kitchen and cooking up a storm.">
                    <meta name="twitter:image" content="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/01/young-rock-banner.png">
            
        <meta property="fb:app_id" content="172826243054377"/>

		

    <link rel="icon" sizes="48x48" href="/public/build/images/favicon-48x48.1311d9e7.png">
    <link rel="icon" sizes="96x96" href="/public/build/images/favicon-96x96.797dd92b.png">
    <link rel="icon" sizes="144x144" href="/public/build/images/favicon-144x144.c2c34bad.png">
    <link rel="icon" sizes="192x192" href="/public/build/images/favicon-192x192.7164dc45.png">
    <link rel="icon" sizes="240x240" href="/public/build/images/favicon-240x240.c24091db.png">

    <link rel="apple-touch-icon" sizes="240x240" href="/public/build/images/favicon-240x240.c24091db.png">
    <link rel="shortcut icon" href="/public/build/images/favicon-192x192.7164dc45.png">

        
        
                                <!-- Using AdsNinja V10 -->
                <!-- Ad Header Start -->
                
                <!-- Ad Header End -->
                
    <!-- GLOABL JS VARIABLES -->
    <script>


    var valnet_site_viewType = "direct";
    var valnet_site_view = "all";
    var valnet_site_campaign = "";
    var valnet_site_device = "desktop";
    var valnet_hideAds = false;
    </script>

</head>

<body class="js-tldr  ">
    <!-- No winning ad found for zone: body injected! -->
    <div id="body-anchor"></div>
        <!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M3N97VF"
                  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

    
    
    
    <div class="w-website">

        <div id="pageStickyFooterAd">
            <div class="close-sticky-footer icon i-close"></div>
            <!-- Zone: sticky footer. -->
<!-- No ads allowed! -->
        </div>

                        <div id="js-header" class="w-header">

    <header class="header" itemscope itemtype="https://schema.org/WPHeader">

        <h1 class="hide" itemprop="headline">collider.com</h1>

        <div class="header-logo">
            <a href="/" title="" rel="home"></a>
        </div>

        <input class="header-menu-btn-input" type="checkbox" id="headerMenu"/>
        <label class="header-menu-btn-label js-nav" for="headerMenu">
            <div class="menu-burger-btn">
                <span class="burger-btn-line"></span>
                <span class="burger-btn-line"></span>
                <span class="burger-btn-line"></span>
            </div>
        </label>

        <div class="w-header-menu">
            <button class="menu-exit-btn icon i-close"></button>
            <div class="header-menu">
                

<nav class="menu-nav" id="menu-site">
    <ul class="menu-nav-list" itemscope itemtype="http://www.schema.org/SiteNavigationElement">
         
                        <li itemprop="name" class="w-drop-down">
                                                            <button class="menu-nav-more-btn js-menu-open">Movies</button>
                                    
                <ul class="drop-down">
                     
                        <li itemprop="name">
                <a href="/all-news/" itemprop="url">Movie News</a>
            </li>
                                <li itemprop="name">
                <a href="/movie-features/" itemprop="url">Movie Features</a>
            </li>
                                <li itemprop="name">
                <a href="/movie-reviews/" itemprop="url">Movie Reviews</a>
            </li>
            

                </ul>
            </li>
                                <li itemprop="name" class="w-drop-down">
                                                            <button class="menu-nav-more-btn js-menu-open">TV</button>
                                    
                <ul class="drop-down">
                     
                        <li itemprop="name">
                <a href="/tv/" itemprop="url">TV News</a>
            </li>
                                <li itemprop="name">
                <a href="/tv-features/" itemprop="url">TV Features</a>
            </li>
                                <li itemprop="name">
                <a href="/tv-reviews/" itemprop="url">TV Reviews</a>
            </li>
            

                </ul>
            </li>
                                <li itemprop="name">
                <a href="/trailers/" itemprop="url">Trailers</a>
            </li>
                                <li itemprop="name" class="w-drop-down">
                                                            <button class="menu-nav-more-btn js-menu-open">Streaming</button>
                                    
                <ul class="drop-down">
                     
                        <li itemprop="name">
                <a href="/netflix/" itemprop="url">Netflix</a>
            </li>
                                <li itemprop="name">
                <a href="/amazon/" itemprop="url">Amazon</a>
            </li>
                                <li itemprop="name">
                <a href="/disney/" itemprop="url">Disney+</a>
            </li>
                                <li itemprop="name">
                <a href="/hbo-max/" itemprop="url">HBO</a>
            </li>
                                <li itemprop="name">
                <a href="/hulu/" itemprop="url">Hulu</a>
            </li>
            

                </ul>
            </li>
                                <li itemprop="name">
                <a href="/interviews/" itemprop="url">Interviews</a>
            </li>
                                <li itemprop="name">
                <a href="/careers/" itemprop="url">Write for Us</a>
            </li>
            

    </ul>
</nav>                                
                                    
    <div class="w-menu-follow">
        <span class="menu-follow-button icon i-social">Follow Us</span>
        <div class="menu-follow drop-down">
                        <div class="menu-follow-social">
                <h4 class="menu-nav-title">Follow Collider</h4>
            	<ul>
                                            <li><a class="icon i-youtube" href="https://www.youtube.com/c/collider" target="_blank"></a></li>
                                            <li><a class="icon i-facebook" href="https://www.facebook.com/collider" target="_blank"></a></li>
                                            <li><a class="icon i-instagram" href="https://www.instagram.com/collider/" target="_blank"></a></li>
                                            <li><a class="icon i-twitter" href="https://twitter.com/collider" target="_blank"></a></li>
                                            <li><a class="icon i-feed" href="https://collider.com/feed/" target="_blank"></a></li>
                    

    	        </ul>
            </div>
            
                            
    <div class="menu-follow-brands">
    	<h4 class="menu-nav-title">Something New</h4>
                                                        <a class="menu-brands-zone icon i-link" href="//screenrant.com" rel="nofollow" target="_blank">
                <img width="300"
                     height="84"
                     class="logo sr"
                     src="/public/build/images/sr-logo-full-colored-light.54036564.svg"
                >
                <div class="desc">
                	Covering the hottest movie and TV topics that fans want.
                </div>
            </a>
                                                                                    <a class="menu-brands-zone icon i-link" href="//cbr.com" rel="nofollow" target="_blank">
                <img width="300"
                     height="84"
                     class="logo cb"
                     src="/public/build/images/cb-logo-full-colored-light.4e17204e.svg"
                >
                <div class="desc">
                	The go-to source for comic book and superhero movie fans.
                </div>
            </a>
            </div>
            

        </div>
    </div>
                
            </div>

        </div>

        
        <button id="js-theme" class="header-theme-btn">
            
<!-- Generator: Adobe Illustrator 25.0.1, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->
<svg version="1.1" class="svg-icon-sun" id="Layer_2" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
	 viewBox="0 0 425.2 425.2" style="enable-background:new 0 0 425.2 425.2;" xml:space="preserve">
<g>
	<path d="M212,319c-59.1,0-107.2-48.1-107.2-107.2c0-59.1,48.1-107.2,107.2-107.2c59.1,0,107.2,48.1,107.2,107.2
		C319.2,270.9,271.1,319,212,319z M212,134.8c-42.5,0-77,34.5-77,77s34.5,77,77,77s77-34.5,77-77S254.5,134.8,212,134.8z"/>
	<g>
		<path d="M313.4,125.6c-3.9,0-7.7-1.5-10.7-4.4c-5.9-5.9-5.9-15.5,0-21.4l35-35c5.9-5.9,15.5-5.9,21.4,0c5.9,5.9,5.9,15.5,0,21.4
			l-35,35C321.1,124.1,317.2,125.6,313.4,125.6z"/>
		<path d="M404.8,226.9h-49.4c-8.3,0-15.1-6.8-15.1-15.1c0-8.3,6.8-15.1,15.1-15.1h49.4c8.3,0,15.1,6.8,15.1,15.1
			C419.9,220.2,413.1,226.9,404.8,226.9z"/>
		<path d="M348.3,363.3c-3.9,0-7.7-1.5-10.7-4.4l-35-35c-5.9-5.9-5.9-15.5,0-21.4c5.9-5.9,15.5-5.9,21.4,0l35,35
			c5.9,5.9,5.9,15.5,0,21.4C356.1,361.8,352.2,363.3,348.3,363.3z"/>
		<path d="M212,419.7c-8.3,0-15.1-6.8-15.1-15.1v-49.4c0-8.3,6.8-15.1,15.1-15.1c8.3,0,15.1,6.8,15.1,15.1v49.4
			C227.1,413,220.4,419.7,212,419.7z"/>
		<path d="M75.7,363.3c-3.9,0-7.7-1.5-10.7-4.4c-5.9-5.9-5.9-15.5,0-21.4l35-35c5.9-5.9,15.5-5.9,21.4,0c5.9,5.9,5.9,15.5,0,21.4
			l-35,35C83.4,361.8,79.6,363.3,75.7,363.3z"/>
		<path d="M68.7,226.9H19.2c-8.3,0-15.1-6.8-15.1-15.1c0-8.3,6.8-15.1,15.1-15.1h49.4c8.3,0,15.1,6.8,15.1,15.1
			C83.8,220.2,77,226.9,68.7,226.9z"/>
		<path d="M110.6,125.6c-3.9,0-7.7-1.5-10.7-4.4l-35-35c-5.9-5.9-5.9-15.5,0-21.4c5.9-5.9,15.5-5.9,21.4,0l35,35
			c5.9,5.9,5.9,15.5,0,21.4C118.4,124.1,114.5,125.6,110.6,125.6z"/>
		<path d="M212,83.6c-8.3,0-15.1-6.8-15.1-15.1V19c0-8.3,6.8-15.1,15.1-15.1c8.3,0,15.1,6.8,15.1,15.1v49.4
			C227.1,76.8,220.4,83.6,212,83.6z"/>
	</g>
</g>
</svg>
            
<!-- Generator: Adobe Illustrator 25.0.1, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->
<svg version="1.1" id="Layer_1" class="svg-icon-moon" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
	 viewBox="0 0 500 500" style="enable-background:new 0 0 500 500;" xml:space="preserve">
<path id="XMLID_814_" d="M412.1,384.9c-136.2,0-246.6-110.4-246.6-246.6c0-47.9,13.7-92.6,37.4-130.5
	C98.6,36.7,22.1,132.1,22.1,245.5c0,136.2,110.4,246.6,246.6,246.6c88.3,0,165.7-46.4,209.2-116.1
	C456.9,381.8,434.9,384.9,412.1,384.9z"/>
</svg>
        </button>

        <button id="js-search" class="header-search-btn icon i-search js-search-target"></button>
    </header>
</div>

<div class="w-header-search js-search-target">
    <button id="js-exit-search" class="header-search-exit icon i-close"></button>
    <div class="header-search">
        <form method="post" class="search-form js-searchBox icon i-search" id="searchform2" action="/search/">
            <input id="js-search-input" type="text" name="keyword" class="input-text search-input" autocomplete="off" id="s2" placeholder="Search Collider" autofocus>
        </form>
    </div>
</div>

<!-- No winning ad found for zone: sticky header! -->

<!-- Zone: header. -->
<!-- No ads allowed! -->


        

        <div class="w-content ">
                <article class="w-article   article">
            



                                                                                                                                                                                               
            
            
                                    
            
            
            


    
                                                                        
        
                        
                            
                
            
                                    
            
            
            


    
                                                                        
        
                        
                            
                
            
                                    
            
            
            


    
                                                    
        
                        
                            
                
                                                            
                                
                            
                                    
            
            
                                                                                    
                                
                                
                                                



            


    
                                                    
                                        
                        
                            
                
            
                                                                                                                                                                                                                                    
            
                                                                                                
                                                                
                                                                                                                                    
                                
                                                



            


    
                                                    
        
                        
                                                            
                
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                            
                
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                            
                
            
                                                                                                                                                                                                                                    
            
            
                                                                                                                                
            


    
                                                    
        
                        
                            
                
            
                                                                                                                                                                                        
            
            
                                                        


    
                                                    
        
                        
                            
                
            
                                                                                                                                                                                                                                                                                                                                                                
            
            
                                                                
                                
                                                                    
                                                



            


    
                                                    
        
                                            
                                                                        
                
            
                                                                                                                                                                                                                                    
            
            
                                                                                                                                                                                                                                                
            


    
                                                    
        
                        
                            
                
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                            
                
            
                                                                                                                                                                                        
            
            
            


    
                                                    
        
                        
                            
                
            
                                                                                                                                                                                                                                    
            
            
                                                                                                                                                                                                                                                
            


    
                                                    
        
                        
                            
                
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                            
                
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                            
                
            
                                                                                                                                                                                                                                                                                                                                                                
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                                            
                            
                
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                            
                
            
                                                                                                                                                                                                                                    
            
            
                                                                                                                                                                                                                                                
            


    
                                                    
        
                        
                            
                
            
                                                                                                                                                                                        
            
            
                                                        


    
                                                    
        
                        
                            
                
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                                                    
                                                



            


    
                                                    
        
                        
                                                                        
                
            
                                                                                                                                                                                                                                                                                                                                                                
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                                            
                            
                
            
                                                                                                                                                                                                                                    
            
            
                                                                                                                                                                                                                                                
            


    
                                                    
        
                        
                            
                
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                            
                
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                            
                
            
                                                                                                                                                                                                                                                                                                                                                                
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                                            
                            
                
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                            
                
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                            
                
            
                                                                                                                                                                                                                                    
            
            
                                                                                                                                                                                                                                                
            


    
                                                    
        
                        
                            
                
            
                                                                                                                                                                                        
            
            
                                                        


    
                                                    
        
                        
                            
                
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                                                    
                                                



            


    
                                                    
        
                        
                                                                        
                
            
                                                                                                                                                                                                                                                                                                                                                                
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                                            
                            
                
            
                                                                                                                                                                                                                                    
            
            
                                                                                                                                                                                                                                                
            


    
                                                    
        
                        
                            
                
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                            
                
            
                                                                                                                                                                                                                                    
            
            
                                                                
                                
                                
                                                



            


    
                                                    
        
                        
                            
                
            
                                                                                                                                                                                        
            
            
                                                                                                                                                                                                                                                
            


    
                                                    
        
                        
                            

<header class="article_heading">
<div class="heading_breadcrumb">
 <script type="application/ld+json">
 {
 "@context": "https://schema.org",
 "@type": "BreadcrumbList",
 "itemListElement": [
 {
 "@type": "ListItem",
 "position": "1",
 "name": "Home",
 "item": "https://www.collider.com/"
 },
 {
 "@type": "ListItem",
 "position":"2",
 "name": "TV Features",
 "item": "https://collider.com/tv-features/"
 }, {
 "@type": "ListItem",
 "position":"3",
 "name": "‘Young Rock’ Season 2: Release Date, Trailer, Cast, and Everything You Need to Know",
 "item": "https://collider.com/young-rock-season-2-release-date-cast-trailer-dwayne-johnson/"
 } ]
 }
 </script>
 <nav>
<ul>
 <li><a href="/">Home</a></li>
 <li><a href="https://collider.com/tv-features/">TV Features</a></li>
 <li><a>‘Young Rock’ Season 2: Release Date, Trailer, Cast, and Everything You Need to Know</a></li>
 </ul>
 </nav>
</div>
<h1 class="heading_title">‘Young Rock’ Season 2: Release Date, Trailer, Cast, and Everything You Need to Know</h1>
<div class="heading_meta">
 <a class="meta_txt author" href="/author/aidan-kelley/">By Aidan Kelley</a>
 <span class="meta_txt date"><time datetime="2022-03-14T15:15:00Z">Published 2 hours ago</time></span>
</div>
<div class="heading_sharing">
<button class="sharing-btn btn-more" onclick="this.parentNode.classList.add('open')">
 <span class="icon i-share"></span>
 <span class="text">Share</span>
</button>
<a class="sharing-btn btn-facebook" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fcollider.com%2Fyoung-rock-season-2-release-date-cast-trailer-dwayne-johnson%2F%2F&amp;src=sdkpreparse">
 <span class="icon i-facebook"></span>
 <span class="text">Share</span>
</a>
<a class="sharing-btn btn-twitter" target="_blank" href="https://twitter.com/intent/tweet?text=%E2%80%98Young%20Rock%E2%80%99%20Season%202%3A%20Release%20Date%2C%20Trailer%2C%20Cast%2C%20and%20Everything%20You%20Need%20to%20Know&url=https%3A%2F%2Fcollider.com%2Fyoung-rock-season-2-release-date-cast-trailer-dwayne-johnson%2F">
 <span class="icon i-twitter"></span>
 <span class="text">Tweet</span>
</a>
<a class="sharing-btn btn-mail" href="mailto:?Subject=‘Young Rock’ Season 2: Release Date, Trailer, Cast, and Everything You Need to Know&Body=Check%20this%20out%21%0Ahttps%3A%2F%2Fhttps://collider.com/young-rock-season-2-release-date-cast-trailer-dwayne-johnson/">
 <span class="icon i-mail-1"></span>
 <span class="text">Email</span>
</a> </div>
<p class="heading_excerpt">Young Rock is back in the kitchen and cooking up a storm.</p>
<div class="heading_image responsive-img img-size-heading-image " style="padding-bottom:50%">
 <figure>
 <picture>
 <!--[if IE 9]>
 <video style="display: none;"><![endif]-->
 <source media="(min-width: 1024px)"
 sizes="750px" srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/01/young-rock-banner.png?q=50&fit=contain&w=750&h=375&dpr=1.5"/>
 <source media="(min-width: 768px)"
 sizes="943px" srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/01/young-rock-banner.png?q=50&fit=contain&w=943&h=500&dpr=1.5"/>
 <source media="(min-width: 481px)"
 sizes="767px" srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/01/young-rock-banner.png?q=50&fit=contain&w=767&h=450&dpr=1.5"/>
 <source media="(min-width: 0px)"
 sizes="480px" srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/01/young-rock-banner.png?q=50&fit=contain&w=480&h=300&dpr=1.5"/>
 <!--[if IE 9]></video><![endif]-->
<img width="1400" height="700" alt="young-rock-banner" data-img-url="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/01/young-rock-banner.png"/>
 </picture>
 <figcaption class="item-img-caption"></figcaption>
 </figure>
</div>
 <!-- No winning ad found for zone: below main pic! -->
</header><section id="article-body" class="article-body" itemprop="articleBody"> 
<p><strong>Dwayne &ldquo;The Rock&rdquo; Johnson</strong> is arguably one of the most famous people in the world, and it&rsquo;s obvious as to why. He&rsquo;s had a hand in nearly every form of popular entertainment, including wrestling, sports, music, and of course, film and television. The legendary multimedia personality and star of the upcoming <a href="https://collider.com/tag/black-adam/"><strong><em>Black Adam</em></strong></a> has enjoyed a long-lasting career that shows no signs of stopping any time soon, but for the longest time, he hadn&rsquo;t really done much in the realm of scripted television besides HBO&rsquo;s <strong><em>Ballers</em></strong>.</p>
 <!-- No winning ad found for zone: word count #1! --><!-- No winning ad found for zone: Below First Paragraph! --><!-- No winning ad found for zone: mid intro! --> 
<p>That was until February 16, 2021, when the first season of <a href="https://collider.com/tag/young-rock/"><strong><em>Young Rock</em></strong></a> premiered. Clearly taking inspiration from sitcoms based on real-life individuals such as <strong><em>Everybody Hates Chris</em></strong>, <em>Young Rock</em> does exactly what the title implies, which is chronicle several events in Dwayne Johnson&rsquo;s life at various ages.</p>
<!-- Zone: character count repeatable. --><!-- No ads allowed! -->
<p>With Season 1 becoming the most-watched sitcom on NBC during 2021, a sophomore outing was practically guaranteed, and it may actually be here sooner than you think. Here&rsquo;s everything there is to know about <em>Young Rock</em> Season 2.</p>
<p><span class="related-single">Related:<a href="https://collider.com/young-rock-review-dwayne-johnson-nbc-show/">&#39;Young Rock&#39; Review: Dwayne Johnson Reveals How He Became a Baller in Unconventional But Charming Comedy</a></span></p>
 <!-- No winning ad found for zone: native in content! -->
<h2 id="when-will-young-rock-season-2-premiere"> When Will Young Rock Season 2 Premiere?</h2>
<div class="body-img landscape">
<div class="responsive-img img-article-item" style="padding-bottom:66.666666666667%">
 <figure>
 <picture>
 <!--[if IE 9]>
 <video style="display: none;"><![endif]-->
 <source media="(min-width: 1024px)"
 sizes="750px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/02/young-rock-joseph-lee-anderson-adrian-groulx-stacey-leilua.jpg?q=50&fit=crop&w=750&dpr=1.5"/>
 <source media="(min-width: 768px)"
 sizes="943px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/02/young-rock-joseph-lee-anderson-adrian-groulx-stacey-leilua.jpg?q=50&fit=crop&w=943&dpr=1.5"/>
 <source media="(min-width: 481px)"
 sizes="767px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/02/young-rock-joseph-lee-anderson-adrian-groulx-stacey-leilua.jpg?q=50&fit=crop&w=767&dpr=1.5"/>
 <source media="(min-width: 0px)"
 sizes="480px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/02/young-rock-joseph-lee-anderson-adrian-groulx-stacey-leilua.jpg?q=50&fit=crop&w=480&dpr=1.5"/>
 <!--[if IE 9]></video><![endif]-->
<img width="3000" height="2000" class="lazyload" alt="Young Rock: Season 1" data-img-url="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/02/young-rock-joseph-lee-anderson-adrian-groulx-stacey-leilua.jpg"/>
 </picture>
 <figcaption class="body-img-caption">Image via NBC</figcaption>
 </figure>
 </div>
 </div>
<p><em>Young Rock</em> will officially return to NBC on Tuesday, March 15, 2022, and then will be available a day later on Peacock to all subscribers. New episodes of course will air with the same conditions every Tuesday. A specific airtime has not yet been officially revealed, but new episodes should also be coming out at whatever that time is every Tuesday after March 15.</p>
 <!-- No winning ad found for zone: word count #2! -->
<div class=ad-odd><!-- No winning ad found for zone: every images #1! --></div>
<h2 id="watch-the-trailer-for-young-rock-season-2"> Watch the Trailer for Young Rock Season 2</h2>
<p>To get a taste of the next serving of <em>Young Rock</em>, check out the quick <strong><a href="https://collider.com/young-rock-trailer-dwayne-johnson/">teaser trailer</a></strong> below:</p>
<!-- Zone: character count repeatable. --><!-- No ads allowed! -->
 <script>
 window.arrayOfEmbeds["1gy4fZzdcUs"] = {'embedded_youtube' : '&quot;&lt;iframe width=\&quot;560\&quot; height=\&quot;315\&quot; src=\&quot;https:\/\/www.youtube.com\/embed\/1gy4fZzdcUs\&quot; frameborder=\&quot;0\&quot; allow=\&quot;accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture\&quot; allowfullscreen&gt;&lt;\/iframe&gt;&quot;'};
</script>
<div class="w-rich w-youtube" id="1gy4fZzdcUs">
 </div>
<div class=ad-even><!-- No winning ad found for zone: every images #2! --></div>
<h2 id="what-is-young-rock-about"> What Is Young Rock About?</h2>
<p>It&hellip;it&rsquo;s about the Rock&hellip;but when he&rsquo;s young&hellip;</p>
<p>Well, while that&rsquo;s not untrue there&rsquo;s a bit more to it than that. Dwayne Johnson is not only the subject of the series, he appears in each episode in a fairly active role. The flashback heavy show actually begins with a flashforward to the year 2032, where The Rock is running for President of the United States.</p>
<p>However, a portion of the American people don&rsquo;t immediately buy into The Rock&rsquo;s legendary and infectious charm, thinking it&rsquo;s all one big facade. To quell this uncertainty, Dwayne Johnson becomes a part of a series of interviews where he candidly talks about his past. The result is the bulk of the show, which are various flashbacks in a non-linear format during three major areas of Johnson&rsquo;s life: his childhood, his teenage years, and his college days.</p>
<!-- Zone: character count repeatable. --><!-- No ads allowed! -->
 <!-- No winning ad found for zone: word count #3! --> 
<p><span class="related-single">Related:<a href="https://collider.com/dwayne-johnson-video-game-adaptation/">Dwayne Johnson Bringing &quot;One of the Biggest, Most Badass Games&quot; to the Screen</a></span></p>
<div class=ad-odd><!-- No winning ad found for zone: every images #3! --></div>
<h2 id="is-young-rock-based-on-a-true-story"> Is Young Rock Based on a True Story?</h2>
<div class="body-img landscape">
<div class="responsive-img img-article-item" style="padding-bottom:66.666666666667%">
 <figure>
 <picture>
 <!--[if IE 9]>
 <video style="display: none;"><![endif]-->
 <source media="(min-width: 1024px)"
 sizes="750px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/02/young-rock-adrian-groulx-matthew-willig.jpg?q=50&fit=crop&w=750&dpr=1.5"/>
 <source media="(min-width: 768px)"
 sizes="943px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/02/young-rock-adrian-groulx-matthew-willig.jpg?q=50&fit=crop&w=943&dpr=1.5"/>
 <source media="(min-width: 481px)"
 sizes="767px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/02/young-rock-adrian-groulx-matthew-willig.jpg?q=50&fit=crop&w=767&dpr=1.5"/>
 <source media="(min-width: 0px)"
 sizes="480px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/02/young-rock-adrian-groulx-matthew-willig.jpg?q=50&fit=crop&w=480&dpr=1.5"/>
 <!--[if IE 9]></video><![endif]-->
<img width="3000" height="2000" class="lazyload" alt="YOUNG ROCK -- "Working The Gimmick" -- Pictured: (l-r)Adrian Groulx as Dwayne, Matthew Willig as Andre The Giant -- (Photo by: Mark Taylor)" data-img-url="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/02/young-rock-adrian-groulx-matthew-willig.jpg"/>
 </picture>
 <figcaption class="body-img-caption">Image via NBC</figcaption>
 </figure>
 </div>
 </div>
<p>Well yes, but as with any major biopic adaptation, <em>Young Rock</em> does take quite a few creative liberties for the sake of more streamlined storytelling. Obviously, the future portions that take place in 2032 are entirely fictionalized (but we&rsquo;re not suggesting that Dwayne Johnson isn&rsquo;t a time traveler, because at this point, why couldn&rsquo;t he be?). Although, there are several characters in the show who make brief appearances in these sections, only this time played by their real-life counterparts instead of the actors who were cast as the younger versions of them.</p>
<p>Certain aspects of the flashback sequences, while partly true, are also occasionally romanticized for smoother narrative purposes. Still, Dwayne Johnson and <em>Young Rock</em> showrunner <a href="https://collider.com/nahnatchka-khan-interview-always-be-my-maybe/"><strong>Nahnatchka Khan</strong></a> (<em>Fresh Off the Boat</em>) maintain that the show is as accurate as humanly possible, with a few major differences being the timeframe of certain sequences even though the content is the same.</p>
<!-- Zone: character count repeatable. --><!-- No ads allowed! -->
 <!-- No winning ad found for zone: word count #4! -->
<div class=ad-even><!-- No winning ad found for zone: every images #4! --></div>
<h2 id="who-is-in-the-cast-of-young-rock-season-2"> Who Is in the Cast of Young Rock Season 2?</h2>
<p>If it wasn&rsquo;t obvious already, Dwayne &ldquo;The Rock&rdquo; Johnson is in the show and makes an appearance in every episode, acting as a sort of narrator for the show&rsquo;s flashbacks.</p>
<p>Three separate actors play Johnson at the three main stages in his life. <strong>Adrian Groulx</strong> portrays child Rock during the early 1980s, being surrounded by his family of wrestlers.<strong> Bradley Constant</strong> plays teenage Rock as he navigates high school and starts to learn how to be mature and provide for his family. Finally, there&rsquo;s <a href="https://collider.com/black-adam-cast-uli-latukefu/"><strong>Uli Latukefu</strong></a> as a college-age Rock, during his days playing football at the University of Miami.</p>
<p>Other prominent characters in the show include Dwayne Johnson&rsquo;s own parents. Firstly there&rsquo;s his mother, <strong>Ata Johnson</strong>, played by <strong>Stacey Leilua</strong>. She&rsquo;s the classic maternal archetype that these sitcoms have become so famous for, showing constant care and protectiveness for her son. Also in the mix is Johnson&rsquo;s father and nick-namesake, <strong>Rocky Johnson</strong>, played by <strong>Joseph Lee Anderson</strong>, the charismatic professional wrestler who is optimistic to a fault.</p>
<!-- Zone: character count repeatable. --><!-- No ads allowed! -->
 <!-- No winning ad found for zone: word count #5! --> 
<p>There also may or may not be a couple of other famous wrestlers and celebrities who appear throughout the show, but those are appearances that are probably better left as surprises.</p>
<p><span class="related-single">Related:<a href="https://collider.com/black-adam-set-image-dwayne-johnson-vfx/">&#39;Black Adam&#39;: Dwayne Johnson Reveals Intricate Behind-the-Scenes Set Image</a></span></p>
<div class=ad-odd><!-- No winning ad found for zone: every images #5! --></div>
<h2 id="is-young-rock-season-2-streaming-online"> Is Young Rock Season 2 Streaming Online?</h2>
<div class="body-img landscape">
<div class="responsive-img img-article-item" style="padding-bottom:50%">
 <figure>
 <picture>
 <!--[if IE 9]>
 <video style="display: none;"><![endif]-->
 <source media="(min-width: 1024px)"
 sizes="750px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/01/young-rock-cast-social.jpg?q=50&fit=crop&w=750&dpr=1.5"/>
 <source media="(min-width: 768px)"
 sizes="943px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/01/young-rock-cast-social.jpg?q=50&fit=crop&w=943&dpr=1.5"/>
 <source media="(min-width: 481px)"
 sizes="767px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/01/young-rock-cast-social.jpg?q=50&fit=crop&w=767&dpr=1.5"/>
 <source media="(min-width: 0px)"
 sizes="480px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/01/young-rock-cast-social.jpg?q=50&fit=crop&w=480&dpr=1.5"/>
 <!--[if IE 9]></video><![endif]-->
<img width="1400" height="700" class="lazyload" alt="young-rock-cast-social" data-img-url="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/01/young-rock-cast-social.jpg"/>
 </picture>
 <figcaption class="body-img-caption">Image via NBCUniversal</figcaption>
 </figure>
 </div>
 </div>
<p>Yes, but if you have access to cable TV or another form of live television, then you&rsquo;ll be able to watch new episodes of <em>Young Rock</em> Season 2 as soon as they come out.</p>
<p><em>Young Rock</em> is an NBC production, so it will appear first on their flagship channel every Tuesday night. However, in case you somehow missed an episode, don&rsquo;t worry, as that same new episode will be available the day after it premieres on Peacock. New episodes will also be available to all Peacock members, including those on the 100% free (with ads) subscription plan</p>
 <!-- No winning ad found for zone: word count #6! -->
<div class=ad-even><!-- No winning ad found for zone: every images #6! --></div>
<h2 id="will-there-be-a-young-rock-season-3"> Will There Be a Young Rock Season 3?</h2>
<p>As of now, <em>Young Rock</em> has been neither canceled nor renewed for a third season. The upcoming second season was announced before Season 1 was even released, which was a smart move on NBC&rsquo;s part given that Season 1 of the hit sitcom was the highest-rated comedy series on the entire channel for the year 2021.</p>
<p>Still, the odds of <em>Young Rock</em> returning for a third season are completely up in the air at this point. The sophomore effort of a show is typically the biggest test of its longevity and popularity that there is, so fans will have to wait to see how many tune in to watch if they want to see The Rock&rsquo;s origin story become a trilogy.</p>
<!-- Zone: character count repeatable. --><!-- No ads allowed! -->
<div class=ad-odd><!-- No winning ad found for zone: every images #7! --></div>
<h2 id=""> </h2>        <div id="article-waypoint"></div>
                                                                                                    


                                                                                                                                                                                                                                                                                                                                                                                                                                                                                    <!-- No winning ad found for zone: above next button! -->
                                                                                            <a class="sentinel-article-nextArticle next-btn" data-content-id="2011094" href="/red-notice-2-3-sequels-ryan-reynolds-dwayne-johnson-gal-gadot/" >
        <div class="next-btn-img">
                            
    
    
<div class="bc-img responsive-img img-article-next-btn">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 768px)"
                        sizes="320px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/12/red-notice-ending-explained.jpg?q=50&fit=crop&w=320&h=240&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="140px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/12/red-notice-ending-explained.jpg?q=50&fit=crop&w=140&h=140&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1400" height="700" class="lazyload" alt="red-notice-ending-explained"/>
                    </picture>
            </figure>
</div>

        </div>
        <div class="next-btn-text lines-trim">
            <strong><span class="next-btn-text-title">'Red Notice': Back-to-Back Sequels Ordered at Netflix With Ryan Reynolds, Dwayne Johnson, Gal Gadot Returning</span></strong>
                            <p class="next-btn-text-p">Yay, more heists.</p>
                    </div>
        <div class="next-btn-cta icon i-arrow-1">Read Next</div>
    </a>
                                        <div class="sharing bottom">
                	
<button class="sharing-btn btn-more" onclick="this.parentNode.classList.add('open')">
	<span class="icon i-share"></span>
	<span class="text">Share</span>
</button>


<a class="sharing-btn btn-facebook" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fcollider.com%2Fyoung-rock-season-2-release-date-cast-trailer-dwayne-johnson%2F%2F&amp;src=sdkpreparse">
	<span class="icon i-facebook"></span>
	<span class="text">Share</span>
</a>

<a class="sharing-btn btn-twitter" target="_blank" href="https://twitter.com/intent/tweet?text=%E2%80%98Young%20Rock%E2%80%99%20Season%202%3A%20Release%20Date%2C%20Trailer%2C%20Cast%2C%20and%20Everything%20You%20Need%20to%20Know&url=https%3A%2F%2Fcollider.com%2Fyoung-rock-season-2-release-date-cast-trailer-dwayne-johnson%2F">
	<span class="icon i-twitter"></span>
	<span class="text">Tweet</span>
</a>

<a class="sharing-btn btn-mail" href="mailto:?Subject=‘Young Rock’ Season 2: Release Date, Trailer, Cast, and Everything You Need to Know&Body=Check%20this%20out%21%0Ahttps%3A%2F%2Fhttps://collider.com/young-rock-season-2-release-date-cast-trailer-dwayne-johnson/">
	<span class="icon i-mail-1"></span>
	<span class="text">Email</span>
</a>            </div>
                                        <div class="article-tags">
	<strong class="section-sub-title">Related Topics</strong>
    <ul>
                                                        <li><a href="/tv/">TV</a></li>
                                    <li><a href="/tv-features/">TV Features</a></li>
                                                                            <li><a class="tags-link" href="/tag/dwayne-the-rock-johnson/">Dwayne "The Rock" Johnson</a></li>
                                    <li><a class="tags-link" href="/tag/young-rock/">Young Rock</a></li>
                                    <li><a class="tags-link" href="/tag/peacock/">Peacock</a></li>
                            	        </ul>
</div>        <!-- No winning ad found for zone: below next button! -->
        <!-- No winning ad found for zone: below sharing options! -->
                    

    
    <strong class="section-sub-title">About The Author</strong>
    <div class="w-article-author-bio">
                    <div class="author-bio-img" >
                                                                                                
                                    <img data-src="https://static1.colliderimages.com/wordpress/wp-content/authors/620174874f391-unnamed.jpg?fit=crop&amp;w=100&amp;h=100" class="lazyload">
                            </div>
                <div class="author-bio-text">

            <strong class="bio-title">Aidan Kelley
                                    <span class="amount">(6 Articles Published)</span>
                            </strong>

                            <div class="bio-social">
                                                                                                                                                                                </div>
            
            <div class="bio-desc">
                <p>My name's Aidan Kelley and I am a resource writer for Collider.</p>
            </div>

                            <a class="bio-btn icon i-arrow-5" href="/author/aidan-kelley/">More
                    From Aidan Kelley</a>
                    </div>

    </div>

                <!-- Zone: below the author. -->
<!-- No ads allowed! -->
                            <div class="newsletter-from" id="newsletter-from">
                <div class="btn-nf-container">
                    <h4>Subscribe to our newsletter</h4>
                    <p>Sign up for Collider&#039;s newsletter for exclusive news, features, streaming recommendations and more</p>
                    <div class="btn-nf">Click here to subscribe</div>
                </div>

                                <script>
                    window.mailChimpAction = 'https://collider.us3.list-manage.com/subscribe/post?u=f99498a069e0ad9583374aa2d&amp;id=3d64521c3f'
                    window.newsletterForm = '&quot;\n&lt;div id=\&quot;mc_embed_signup_scroll\&quot;&gt;\n\t&lt;div class=\&quot;mc-field-group\&quot;&gt;\n\t\t&lt;label for=\&quot;mce-EMAIL\&quot;&gt;Email Address&lt;\/label&gt;\n\t\t&lt;input type=\&quot;email\&quot; value=\&quot;\&quot; name=\&quot;EMAIL\&quot; class=\&quot;required email\&quot; id=\&quot;mce-EMAIL\&quot; placeholder=\&quot;your@email.com\&quot;&gt;\n\t&lt;\/div&gt;\n\t&lt;div id=\&quot;mce-responses\&quot; class=\&quot;clear foot\&quot;&gt;\n\t\t&lt;div class=\&quot;response\&quot; id=\&quot;mce-error-response\&quot; style=\&quot;display:none\&quot;&gt;&lt;\/div&gt;\n\t\t&lt;div class=\&quot;response\&quot; id=\&quot;mce-success-response\&quot; style=\&quot;display:none\&quot;&gt;&lt;\/div&gt;\n\t&lt;\/div&gt;\n\n\t&lt;div style=\&quot;position: absolute; left: -5000px;\&quot; aria-hidden=\&quot;true\&quot;&gt;\n\t\t&lt;input type=\&quot;text\&quot;\n\t\t\t   name=\&quot;b_f99498a069e0ad9583374aa2d_3d64521c3f\&quot;\n\t\t\t   tabindex=\&quot;-1\&quot; value=\&quot;\&quot;&gt;\n\t&lt;\/div&gt;\n\t&lt;div class=\&quot;optionalParent\&quot;&gt;\n\t\t&lt;input type=\&quot;submit\&quot; value=\&quot;Submit\&quot; name=\&quot;subscribe\&quot; id=\&quot;mc-embedded-subscribe\&quot; class=\&quot;button mc-button\&quot;&gt;\n\t&lt;\/div&gt;\n&lt;\/div&gt;\n\n\n&quot;';
                </script>

                <div id="mc_embed_signup" style="display: none">
                    <form action="https://collider.us3.list-manage.com/subscribe/post?u=f99498a069e0ad9583374aa2d&amp;id=3d64521c3f"
                          method="post"
                          id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate"
                          target="_blank" novalidate>
                    </form>
                </div>

            </div>
                                </section>
        
<aside id="secondary" class="sidebar" role="complementary">

    <!-- No winning ad found for zone: sidebar top! -->
            <!-- No winning ad found for zone: first! -->

    
                                                            <section class="sidebar-trending ">
                                                                            <div class="sidebar-button sidebar-netflix">
                                



                                
                                
                                
    
        
                        


    

<article class="browse-clip  js-content" data-content-id=":499469">
        <a class="bc-img-link" href="/best-movies-on-netflix-streaming/" >
                    
    
    
<div class="bc-img responsive-img img-netflix-sidebar">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="350px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/12/BEST-MOVIES-ON-NETFLIX.jpg?q=50&fit=crop&w=350&h=210&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="320px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/12/BEST-MOVIES-ON-NETFLIX.jpg?q=50&fit=crop&w=320&h=260&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="400px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/12/BEST-MOVIES-ON-NETFLIX.jpg?q=50&fit=crop&w=400&h=320&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="240px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/12/BEST-MOVIES-ON-NETFLIX.jpg?q=50&fit=crop&w=240&h=180&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1400" height="700" class="lazyload" alt="BEST-MOVIES-ON-NETFLIX"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
    
    
                <div class="bc-details">

                
                
                
                                                            <time class="bc-date" datetime="2022-03-11T21:00:17Z">3 days ago</time>
                                    
                
                
            </div>
                
        </div>
    
    
    

</article>

                            </div>
                                                                            <div class="section-header">
                            <h3 class="section-title">Trending</h3>
                        </div>
                                <div class="sentinel-article-sidebarTop browse-grid clip-full col-1">
                                                                                                                    



                                
                                
    



    

<article class="browse-clip  item-1 js-content" data-content-id=":2014867">
        <a class="bc-img-link" href="/clint-eastwood-sideshow-collectibles-dirty-harry-man-with-no-name-figures/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/Clint-Eastwood-Sideshow-figure.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/Clint-Eastwood-Sideshow-figure.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/Clint-Eastwood-Sideshow-figure.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/Clint-Eastwood-Sideshow-figure.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1400" height="700" class="lazyload" alt="Clint-Eastwood-Sideshow-figure"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/clint-eastwood-sideshow-collectibles-dirty-harry-man-with-no-name-figures/" class="bc-title-link" title="Sideshow Collectibles Releases Clint Eastwood Figures From &#039;Dirty Harry&#039; and &#039;The Man With No Name&#039;" >Sideshow Collectibles Releases Clint Eastwood Figures From &#039;Dirty Harry&#039; and &#039;The Man With No Name&#039;</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                                                                            







    

<article class="browse-clip  item-2 js-content" data-content-id=":2015058">
        <a class="bc-img-link" href="/killing-eve-season-4-episode-3-recap-a-rainbow-in-beige-boots/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/killing-eve-season-4-episode-3-bbc-america-social-featured.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/killing-eve-season-4-episode-3-bbc-america-social-featured.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/killing-eve-season-4-episode-3-bbc-america-social-featured.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/killing-eve-season-4-episode-3-bbc-america-social-featured.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1400" height="700" class="lazyload" alt="killing-eve-season-4-episode-3-bbc-america-social-featured"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/killing-eve-season-4-episode-3-recap-a-rainbow-in-beige-boots/" class="bc-title-link" title="&#039;Killing Eve&#039; Season 4 Episode 3 Recap: Sibling Rivalry and an Arresting Attempt at Change " >&#039;Killing Eve&#039; Season 4 Episode 3 Recap: Sibling Rivalry and an Arresting Attempt at Change </a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                                                                                                        







    

<article class="browse-clip  item-3 js-content" data-content-id=":2014390">
        <a class="bc-img-link" href="/best-90s-sitcom-siblings/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/The-Ultimate-‘90s-Sitcom-Siblings.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/The-Ultimate-‘90s-Sitcom-Siblings.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/The-Ultimate-‘90s-Sitcom-Siblings.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/The-Ultimate-‘90s-Sitcom-Siblings.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1400" height="700" class="lazyload" alt="The-Ultimate-‘90s-Sitcom-Siblings"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/best-90s-sitcom-siblings/" class="bc-title-link" title="The Ultimate ‘90s Sitcom Siblings From the Gellers to the Taylors " >The Ultimate ‘90s Sitcom Siblings From the Gellers to the Taylors </a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                            <!-- Zone: second. -->
<!-- No ads allowed! -->
                                                                                                                        







    

<article class="browse-clip  item-4 js-content" data-content-id=":2014273">
        <a class="bc-img-link" href="/kingsman-movies-franchise-lost-its-way/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/The-Fall-of-The-Kingsman-Franchise.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/The-Fall-of-The-Kingsman-Franchise.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/The-Fall-of-The-Kingsman-Franchise.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/The-Fall-of-The-Kingsman-Franchise.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1400" height="700" class="lazyload" alt="The-Fall-of-The-Kingsman-Franchise"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/kingsman-movies-franchise-lost-its-way/" class="bc-title-link" title="Manners Maketh A Movie: The Fall of The &#039;Kingsman&#039; Franchise" >Manners Maketh A Movie: The Fall of The &#039;Kingsman&#039; Franchise</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                                                                                                        



                                
                                
    



    

<article class="browse-clip  item-5 js-content" data-content-id=":2014773">
        <a class="bc-img-link" href="/gotham-knights-release-date-revealed-video-game/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/10/gotham-knights-social.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/10/gotham-knights-social.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/10/gotham-knights-social.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/10/gotham-knights-social.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1400" height="700" class="lazyload" alt="gotham-knights-social"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/gotham-knights-release-date-revealed-video-game/" class="bc-title-link" title="&#039;Gotham Knights&#039; Release Date Reveals When Fans Can Play Batman&#039;s Sidekicks" >&#039;Gotham Knights&#039; Release Date Reveals When Fans Can Play Batman&#039;s Sidekicks</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                                                                                                        



                                
                                
    



    

<article class="browse-clip  item-6 js-content" data-content-id=":2015024">
        <a class="bc-img-link" href="/the-batman-box-office-second-weekend-66-million/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/12/the-batman-trailer-social-featured-1.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/12/the-batman-trailer-social-featured-1.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/12/the-batman-trailer-social-featured-1.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/12/the-batman-trailer-social-featured-1.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1400" height="700" class="lazyload" alt="the-batman-trailer-social-featured-1"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/the-batman-box-office-second-weekend-66-million/" class="bc-title-link" title="‘The Batman’ Repeats With $66 Million Second Weekend Box Office, Has a Better Hold Than ‘The Dark Knight’ " >‘The Batman’ Repeats With $66 Million Second Weekend Box Office, Has a Better Hold Than ‘The Dark Knight’ </a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                        </div>
                                                                    <!-- No winning ad found for zone: third! -->
                                            </section>
                                                                
        

        
                                                                                                <section class="sidebar-sticky ">
                        <!-- Zone: default. -->
<!-- No ads allowed! -->
                        <div class="section-header">
                            <h3 class="section-title">trending now</h3>
                        </div>
                                <div class="sentinel-article-sidebarSticky browse-half clip-half">
                                                                                                



                                
                                
    



    

<article class="browse-clip  item-1 js-content" data-content-id=":2014989">
        <a class="bc-img-link" href="/umbrella-academy-release-date-season-3-sparrows/" >
                    
    
    
<div class="bc-img responsive-img img-size-half">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="316px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/the-umbrella-academy-cast-season-3-social.jpg?q=50&fit=crop&w=316&h=223&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="377px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/the-umbrella-academy-cast-season-3-social.jpg?q=50&fit=crop&w=377&h=300&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="294px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/the-umbrella-academy-cast-season-3-social.jpg?q=50&fit=crop&w=294&h=234&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="180px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/the-umbrella-academy-cast-season-3-social.jpg?q=50&fit=crop&w=180&h=130&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1400" height="700" class="lazyload" alt="the-umbrella-academy-cast-season-3-social"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/umbrella-academy-release-date-season-3-sparrows/" class="bc-title-link" title="&#039;The Umbrella Academy&#039; Season 3 Teaser Reveals Release Date and the Sparrows" >&#039;The Umbrella Academy&#039; Season 3 Teaser Reveals Release Date and the Sparrows</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                                                                            



                                
                                
    



    

<article class="browse-clip  item-2 js-content" data-content-id=":2015070">
        <a class="bc-img-link" href="/embrace-the-panda-making-turning-red-trailer-making-of-documentary-pixar/" >
                    
    
    
<div class="bc-img responsive-img img-size-half">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="316px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/imgonline-com-ua-resize-otL7c3eW5s4Sd.jpg?q=50&fit=crop&w=316&h=223&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="377px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/imgonline-com-ua-resize-otL7c3eW5s4Sd.jpg?q=50&fit=crop&w=377&h=300&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="294px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/imgonline-com-ua-resize-otL7c3eW5s4Sd.jpg?q=50&fit=crop&w=294&h=234&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="180px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/imgonline-com-ua-resize-otL7c3eW5s4Sd.jpg?q=50&fit=crop&w=180&h=130&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1400" height="700" class="lazyload" alt="embrace-the-panda-making-turning-red"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/embrace-the-panda-making-turning-red-trailer-making-of-documentary-pixar/" class="bc-title-link" title="‘Embrace the Panda: Making Turning Red’ Trailer Goes Behind the Scenes of Pixar’s Newest Film" >‘Embrace the Panda: Making Turning Red’ Trailer Goes Behind the Scenes of Pixar’s Newest Film</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                                                                            







    

<article class="browse-clip  item-3 js-content" data-content-id=":2013376">
        <a class="bc-img-link" href="/shining-vale-cast-character-guide-starz/" >
                    
    
    
<div class="bc-img responsive-img img-size-half">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="316px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/shining-vale.jpg?q=50&fit=crop&w=316&h=223&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="377px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/shining-vale.jpg?q=50&fit=crop&w=377&h=300&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="294px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/shining-vale.jpg?q=50&fit=crop&w=294&h=234&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="180px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/shining-vale.jpg?q=50&fit=crop&w=180&h=130&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1400" height="700" class="lazyload" alt="shining-vale"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/shining-vale-cast-character-guide-starz/" class="bc-title-link" title="&#039;Shining Vale&#039; Cast &amp; Character Guide: Who Plays Who in the Paranormal Horror-Comedy" >&#039;Shining Vale&#039; Cast &amp; Character Guide: Who Plays Who in the Paranormal Horror-Comedy</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                        </div>
                                                            </section>
                                    
    
</aside>
    </article>
    <section class="w-article-related">
    <!-- No winning ad found for zone: trending #1! -->

    <div class="section-header">
                                 <h3 class="section-title related">Read Next in television</h3>
                        </div>


    <div class="sentinel-article-relatedContent browse-grid col-1 col-t-2 col-d-4 clip-full">
                    



                                
                                
    



    

<article class="browse-clip  js-content" data-content-id=":2015031">
        <a class="bc-img-link" href="/sonic-2-faster-trailer-easter-eggs/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/02/sonic-character-poster-social.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/02/sonic-character-poster-social.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/02/sonic-character-poster-social.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/02/sonic-character-poster-social.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1400" height="700" class="lazyload" alt="sonic character poster social"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/sonic-2-faster-trailer-easter-eggs/" class="bc-title-link" title="&#039;Sonic The Hedgehog 2&#039; Reveals Easter Egg Filled &quot;Faster Trailer&quot; Ahead of Final Trailer Tomorrow" >&#039;Sonic The Hedgehog 2&#039; Reveals Easter Egg Filled &quot;Faster Trailer&quot; Ahead of Final Trailer Tomorrow</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                







    

<article class="browse-clip  js-content" data-content-id=":2014042">
        <a class="bc-img-link" href="/the-cw-90210-every-season-ranked/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/cw-90210-seasons-ranked.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/cw-90210-seasons-ranked.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/cw-90210-seasons-ranked.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/cw-90210-seasons-ranked.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1400" height="700" class="lazyload" alt="cw-90210-seasons-ranked"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/the-cw-90210-every-season-ranked/" class="bc-title-link" title="The CW&#039;s &#039;90210&#039;: All Five Seasons Ranked from Worst to Best" >The CW&#039;s &#039;90210&#039;: All Five Seasons Ranked from Worst to Best</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                







    

<article class="browse-clip  js-content" data-content-id=":2014686">
        <a class="bc-img-link" href="/the-batman-martha-wayne-explained-arkham/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/The-Batman-Martha-Wayne.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/The-Batman-Martha-Wayne.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/The-Batman-Martha-Wayne.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/The-Batman-Martha-Wayne.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1400" height="700" class="lazyload" alt="The-Batman-Martha-Wayne"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/the-batman-martha-wayne-explained-arkham/" class="bc-title-link" title="‘The Batman’: What’s The Deal with Martha Wayne?" >‘The Batman’: What’s The Deal with Martha Wayne?</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                            <!-- No winning ad found for zone: trending #2! -->
                                



                                
                                
    



    

<article class="browse-clip  js-content" data-content-id=":2014990">
        <a class="bc-img-link" href="/man-who-fell-to-earth-first-5-minutes-video-showtime/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/02/imgonline-com-ua-resize-EDnDSn1qnA.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/02/imgonline-com-ua-resize-EDnDSn1qnA.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/02/imgonline-com-ua-resize-EDnDSn1qnA.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/02/imgonline-com-ua-resize-EDnDSn1qnA.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1400" height="700" class="lazyload" alt="man-who-fell-to-earth-chiwetel-ejiofor"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/man-who-fell-to-earth-first-5-minutes-video-showtime/" class="bc-title-link" title="&#039;The Man Who Fell to Earth&#039;: Watch the First 5 Minutes of Showtime&#039;s New Sci-Fi Series" >&#039;The Man Who Fell to Earth&#039;: Watch the First 5 Minutes of Showtime&#039;s New Sci-Fi Series</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                



                                
                                
    



    

<article class="browse-clip  js-content" data-content-id=":2014919">
        <a class="bc-img-link" href="/dune-3-messiah-denis-villeneuve-comments-dune-2/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/10/Timothee-Chalamet-and-Zendaya-dune-interview-social.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/10/Timothee-Chalamet-and-Zendaya-dune-interview-social.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/10/Timothee-Chalamet-and-Zendaya-dune-interview-social.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/10/Timothee-Chalamet-and-Zendaya-dune-interview-social.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1400" height="700" class="lazyload" alt="Timothee Chalamet and Zendaya dune interview social"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/dune-3-messiah-denis-villeneuve-comments-dune-2/" class="bc-title-link" title="Denis Villeneuve Says an Adaptation of &#039;Dune Messiah&#039; Might Come After &#039;Dune: Part Two&#039;" >Denis Villeneuve Says an Adaptation of &#039;Dune Messiah&#039; Might Come After &#039;Dune: Part Two&#039;</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                







    

<article class="browse-clip  js-content" data-content-id=":2014265">
        <a class="bc-img-link" href="/best-flight-of-the-conchords-songs/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/flight-of-the-conchords-best-songs.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/flight-of-the-conchords-best-songs.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/flight-of-the-conchords-best-songs.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/flight-of-the-conchords-best-songs.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1400" height="700" class="lazyload" alt="flight-of-the-conchords-best-songs"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/best-flight-of-the-conchords-songs/" class="bc-title-link" title="‘Flight of the Conchords’: 10 Best Songs From Hurt Feelings to Epileptic Dogs" >‘Flight of the Conchords’: 10 Best Songs From Hurt Feelings to Epileptic Dogs</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                            <!-- No winning ad found for zone: trending #3! -->
                                



                                
                                
    



    

<article class="browse-clip  js-content" data-content-id=":2014193">
        <a class="bc-img-link" href="/best-hollywood-movie-vehicles-that-arent-batmobile/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/iconic-vehicles-that-arent-batmobile.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/iconic-vehicles-that-arent-batmobile.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/iconic-vehicles-that-arent-batmobile.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/iconic-vehicles-that-arent-batmobile.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1400" height="700" class="lazyload" alt="iconic-vehicles-that-arent-batmobile"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/best-hollywood-movie-vehicles-that-arent-batmobile/" class="bc-title-link" title="10 Iconic Vehicles from Hollywood (That Aren&#039;t Batsomething)" >10 Iconic Vehicles from Hollywood (That Aren&#039;t Batsomething)</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                



                                
                                
                                
    



    

<article class="browse-clip  js-content" data-content-id=":2012421">
        <a class="bc-img-link" href="/how-to-watch-death-on-the-nile-streaming-where-theaters/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/02/How-To-Watch-Death-On-The-Nile.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/02/How-To-Watch-Death-On-The-Nile.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/02/How-To-Watch-Death-On-The-Nile.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/02/How-To-Watch-Death-On-The-Nile.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1400" height="700" class="lazyload" alt="How-To-Watch-Death-On-The-Nile"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/how-to-watch-death-on-the-nile-streaming-where-theaters/" class="bc-title-link" title="How To Watch ‘Death On The Nile’: Where to Stream the Agatha Christie Movie" >How To Watch ‘Death On The Nile’: Where to Stream the Agatha Christie Movie</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                                



                                
                                
    



    

<article class="browse-clip  js-content" data-content-id=":2014806">
        <a class="bc-img-link" href="/lewis-hamilton-formula-one-documentary-apple-tv-plus/" >
                    
    
    
<div class="bc-img responsive-img img-size-full">
    <figure>
        <picture>
            <!--[if IE 9]>
            <video style="display: none;"><![endif]-->
                            <source media="(min-width: 1024px)"
                        sizes="330px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/sir-lewish-hamilton.jpg?q=50&fit=crop&w=330&h=170&dpr=1.5"/>
                            <source media="(min-width: 768px)"
                        sizes="943px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/sir-lewish-hamilton.jpg?q=50&fit=crop&w=943&h=450&dpr=1.5"/>
                            <source media="(min-width: 481px)"
                        sizes="737px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/sir-lewish-hamilton.jpg?q=50&fit=crop&w=737&h=413&dpr=1.5"/>
                            <source media="(min-width: 0px)"
                        sizes="450px" data-srcset="https://static1.colliderimages.com/wordpress/wp-content/uploads/2022/03/sir-lewish-hamilton.jpg?q=50&fit=crop&w=450&h=250&dpr=1.5"/>
            
            <!--[if IE 9]></video><![endif]-->
                            <img width="1400" height="700" class="lazyload" alt="sir-lewish-hamilton"/>
                    </picture>
            </figure>
</div>


            </a>


            <div class="bc-info">
    
            
            
            <h3 class="bc-title">
                        
                                        
                                                    <a href="/lewis-hamilton-formula-one-documentary-apple-tv-plus/" class="bc-title-link" title="Formula One World Champion Sir Lewis Hamilton to Get Documentary at Apple TV+" >Formula One World Champion Sir Lewis Hamilton to Get Documentary at Apple TV+</a>
        </h3>
    
    
            
        </div>
    
    
    

</article>

                        </div>
</section>

    
        </div>

            
    
                

            





        



<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "Article",
        "mainEntityOfPage": {
            "@type": "WebPage",
            "@id": "https://www.collider.com/young-rock-season-2-release-date-cast-trailer-dwayne-johnson/"
        },
        "headline": "Young Rock Season 2: Release Date, Trailer, &amp;amp; Everything You Need to Know ",
        "image":{
            "@type": "ImageObject",
            "url": "https://static1.colliderimages.com/wordpress/wp-content/uploads/2021/01/young-rock-banner.png",
            "height":700,
            "width":1400
        },
        "datePublished": "2022-03-14T15:15:14Z",
        "dateModified": "2022-03-14T15:15:14Z",
            "author": {
            "@type": "Person",
            "@id" :  "https://www.collider.com/author/aidan-kelley/#author",
            "name": "Aidan Kelley",
            "sameAs":[
                 "https://www.collider.com/author/aidan-kelley/"
            ]
        },
        "publisher": {
            "@type": "Organization",
            "@id": "https://www.collider.com/#organization",
            "name": "Collider",
            "sameAs": [
            "https://www.youtube.com/c/collider",
            "https://www.facebook.com/collider",
            "https://www.instagram.com/collider/",
            "https://twitter.com/collider"    
        ],

            "logo": {
                "@type": "ImageObject",
                "url": "https://www.collider.com/public/build/images/cl-amp-logo.93e10fe7.png",
                "height":121,
                "width":373
            }
        },
        "articleSection":["tv-features","dwayne-the-rock-johnson","young-rock","peacock"],
                "description": "Here&#039;s everything we know so far about Dwayne Johnson&#039;s Young Rock Season 2, including updates on the release date, trailer, cast, and more."
    }
</script>

    
                    
<!-- Zone: footer. -->
<!-- No ads allowed! -->

    
<footer class="w-footer">
        <div class="footer">
                        <nav class="menu-legal">
        <ul>
                                                                <li><a class="write" href="/careers/">Write For Us</a></li>
                                                                                <li><a class="menu-home" href="/">Home</a></li>
                                                                                <li><a class="menu-contact-us" href="/contact/">Contact Us</a></li>
                                                                                <li><a class="menu-terms" href="/terms-of-use/">Terms</a></li>
                                                                                <li><a class="menu-privacy" href="/privacy-policy/">Privacy</a></li>
                                                                                <li><a class="menu-copyright" href="/dmca-take-down-policy/">Copyright</a></li>
                                                                                <li><a class="menu-about-us" href="/about/">About Us</a></li>
                                                                                <li><a class="menu-fact-checking-policy" href="/fact-checking-policy/">Fact Checking Policy</a></li>
                                                                                <li><a class="menu-corrections-policy" href="/corrections-policy/">Corrections Policy</a></li>
                                                                                <li><a class="menu-ethics-policy" href="/ethics-policy/">Ethics Policy</a></li>
                                                                                <li><a class="menu-ownership-policy" href="/ownership-funding-advertising-policy/">Ownership Policy</a></li>
                                                                                <li><a class="menu-partnership-disclaimer" href="/partnership-disclaimer/">Partnership Disclaimer</a></li>
                                    </ul>
    </nav>

        	</div>
	<div class="footer-copy">
		Copyright &copy; 2022 collider.com
	</div>
</footer>

        
    </div>

                    <script src="/public/build/valnet-footer.5fb0c657.js" async></script>
    
        <script src="/public/build/valnet-footer-article.b3c40a38.js" async></script>
        <script>
                    var isPreview =  false
                    </script>

        
            <script type='text/javascript' src='//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js' async></script>
    


    

        <script>
        document.addEventListener('DOMContentLoaded', function () {
            var queryString = window.location.search || '';
            var keyValPairs = [];
            var params      = {};

            queryString     = queryString.substr(1);
            if (queryString.length)
            {
                keyValPairs = queryString.split('&');
                for (var i = 0; i < keyValPairs.length; i++)
                {
                    var key = keyValPairs[i].split('=')[0];
                    if (!key.length) continue;
                    if (typeof params[key] === 'undefined')
                        params[key] = [];
                    params[key].push(keyValPairs[i].split('=')[1]);
                }

                if (params['view'] !== undefined) {
                    if (params['view'] == "list" || params['view'] == "lista") {
                        valnet_cookie.set("view",params['view']);
                    }
                }

                var campaign = null;
                if (params['utm_source'] !== undefined) {
                    campaign = params['utm_source'];
                }
                if (campaign !== null) {
                    valnet_cookie.set("campaign",campaign);
                }
            }
        });
    </script>

                            <!-- Using AdsNinja V10 -->
            <!-- Ad Footer Start -->
            
            <!-- Ad Footer End -->
            

                                                        
    <script>

        console.log('viewType: direct');
        console.log('view: all');
        console.log('campaign: ');
        console.log('device: desktop');
                console.log('displayStartButton:  false ');
        
    </script>

    

    
 </body>
</html>

